CVE-2019-0728

HIGH

Description

A remote code execution vulnerability exists in Visual Studio Code when it process environment variables after opening a project, aka 'Visual Studio Code Remote Code Execution Vulnerability'.

References

http://seclists.org/fulldisclosure/2019/Apr/38

http://www.openwall.com/lists/oss-security/2019/04/30/4

http://www.securityfocus.com/bid/106913

https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-0728

Details

Source: MITRE

Published: 2019-03-05

Updated: 2019-05-03

Type: CWE-94

Risk Information

CVSS v2.0

Base Score: 9.3

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 8.6

Severity: HIGH

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.8

Severity: HIGH