Node.js 18.x < 18.20.2 / 20.x < 20.12.2 / 21.x < 21.7.3 の複数の脆弱性 (2024 年 4 月 10 日水曜日のセキュリティリリース)。

high Nessus プラグイン ID 193580

概要

Node.js - JavaScript Runtime Environment は複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされている Node.js のバージョンは、18.20.2、20.12.2、21.7.3より前のものです。したがって、2024 年 4 月 10 日水曜日のセキュリティリリースのアドバイザリに記載されているとおり、複数の脆弱性の影響を受けます。

- child_process.spawn / child_process.spawnSync のバッチファイルの不適切な処理により、シェルオプションが有効でなくても、悪意のあるコマンドライン引数が任意のコマンドを注入してコードを実行する可能性があります。

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

Node.js のバージョンを 18.20.2/20.12.2/21.7.3 以降にアップグレードしてください。

参考資料

http://www.nessus.org/u?0f839ef4

プラグインの詳細

深刻度: High

ID: 193580

ファイル名: nodejs_2024_apr_extra.nasl

バージョン: 1.2

タイプ: local

エージェント: windows, macosx, unix

ファミリー: Misc.

公開日: 2024/4/19

更新日: 2024/6/14

設定: 徹底したチェックを有効にする

サポートされているセンサー: Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

基本値: 7.2

現状値: 5.3

ベクトル: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2024-27980

CVSS v3

リスクファクター: High

基本値: 8.4

現状値: 7.3

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:nodejs:node.js

必要な KB アイテム: installed_sw/Node.js, SMB/Registry/Enumerated

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/4/9

脆弱性公開日: 2024/4/9

参照情報

CVE: CVE-2024-27980