Tenable SecurityCenter Apache 2.4.x < 2.4.25の複数の脆弱性(TNS-2017-04)(httpoxy)

high Nessus プラグイン ID 101044
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストのTenable SecurityCenterアプリケーションには、複数の脆弱性の影響を受けるWebサーバーが含まれます。

説明

リモートホストにインストールされているTenable SecurityCenterアプリケーションには、セキュリティパッチがありません。そのため、Apacheのバンドル版にある複数の脆弱性の影響を受けます。- データとCookieがCBCまたはECBの動作モード(デフォルトではAES256-CBC)で構成された暗号によって暗号化されているため、mod_session_cryptoモジュールに欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、暗号鍵を知らなくてもパディングオラクル攻撃を通じて情報を復号して、秘密情報を漏えいする可能性があります。(CVE-2016-0736)- クライアントエントリの割り当て中に、mod_auth_digestモジュールにサービス拒否の脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工された入力で共有メモリリソースを枯渇させ、サーバークラッシュを引き起こす可能性があります。(CVE-2016-2161)- RFC 3875セクション4.1.18にしたがって名前空間の競合を適切に解決できないため、Apache HTTP Serverは「httpoxy」として知られる中間者の脆弱性の影響を受けます。HTTP_PROXY環境変数が、HTTPリクエストの「Proxy」ヘッダーの信頼できないユーザーデータに基づいて設定されます。HTTP_PROXY環境変数が、リモートプロキシサーバーを指定するために、一部のWebクライアントライブラリにより使用されます。認証されていないリモートの攻撃者がこれを悪用し、HTTPリクエストの細工された「Proxy」ヘッダーを通じて、アプリケーションの内部HTTPトラフィックを任意のプロキシサーバーにリダイレクトする可能性があります。このプロキシサーバーは、観察または操作が行われる可能性があります。(CVE-2016-5387)- LimitRequestFieldsディレクティブが不適切に処理されているため、mod_http2モジュールにサービス拒否の脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、HTTP/2リクエストで特別に細工されたCONTINUATIONフレームを介して無制限のリクエストヘッダーをサーバーに挿入し、メモリリソースを枯渇させる可能性があります。(CVE-2016-8740)- ユーザーエージェントヘッダーの空白パターンが不適切に処理されているため、欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたユーザーエージェントヘッダーを使用してプログラムに誤ってリクエストシーケンスを処理させ、誤って応答を解釈させたり、キャッシュを汚染させたり、あるリクエストからのコンテンツを次の下流ユーザーエージェントに漏えいさせたりする可能性があります。(CVE-2016-8743) Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Tenable SecurityCenterバージョン5.4.3以降にアップグレードしてください。または、パッチについてベンダーにお問い合わせください。

関連情報

https://www.tenable.com/security/tns-2017-04

https://static.tenable.com/prod_docs/upgrade_security_center.html

http://httpd.apache.org/security/vulnerabilities_24.html

プラグインの詳細

深刻度: High

ID: 101044

ファイル名: securitycenter_apache_2_4_25.nasl

バージョン: 1.8

タイプ: combined

エージェント: unix

ファミリー: Misc.

公開日: 2017/6/26

更新日: 2020/10/9

依存関係: securitycenter_installed.nbin, securitycenter_detect.nbin

リスク情報

CVSS スコアのソース: manual

CVSS スコアの根本的理由: Score based on analysis of the vendor advisory.

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.1

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:tenable:securitycenter

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2017/2/9

脆弱性公開日: 2016/7/18

参照情報

CVE: CVE-2016-0736, CVE-2016-2161, CVE-2016-5387, CVE-2016-8740, CVE-2016-8743

BID: 91816, 94650, 95076, 95077, 95078

CERT: 797896

EDB-ID: 40961