Tenable SecurityCenter OpenSSL 1.0.1 < 1.0.1uの複数の脆弱性(SWEET32)

critical Nessus プラグイン ID 101045
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストのTenable SecurityCenterアプリケーションには、複数の脆弱性の影響を受けるOpenSSLライブラリが含まれています。

説明

リモートホストにインストールされているTenable SecurityCenterアプリケーションには、セキュリティパッチがありません。そのため、OpenSSLのバンドル版の複数の脆弱性の影響を受けます。- s3_srvr.c、ssl_sess.c、t1_lib.cに複数の整数オーバーフロー条件があります。これは、ヒープバッファ境界チェックのためのポインター冤罪の不適切な使用によるものです。認証されていないリモートの攻撃者がこの問題を悪用し、サービス拒否を引き起こす可能性があります。(CVE-2016-2177)- 定数時間操作の使用が適切に保証されていないため、情報漏えいの脆弱性がdsa_ossl.cのdsa_sign_setup()関数にあります。認証されていないリモートの攻撃者がこれを悪用し、サイドチャネルのタイミング攻撃を仕掛け、DSAキー情報を漏えいさせる可能性があります。(CVE-2016-2178)- 使われていない「故障」メッセージに関連付けられているキューエントリの有効期間が正しく制限できないため、サービス拒否の脆弱性がDTLS実装にあります。認証されていないリモートの攻撃者がこれを悪用し、細工されたDTLSセッションを複数同時に維持することでメモリ不足にさせることがあります。(CVE-2016-2179)- X.509公開鍵インフラストラクチャのタイムスタンププロトコル(TSP)実装に領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、細工されたタイムスタンプファイルを介して「openssl ts」コマンドに間違った処理をさせることで、サービス拒否を引き起こしたり、秘密情報を漏えいさせたりする可能性があります。(CVE-2016-2180)- レコードのエポックシーケンス番号が不適切に処理されているため、サービス拒否の脆弱性がDTLS実装のアンチリプレイ機能にあります。認証されていないリモートの攻撃者がこれを悪用し、DTLSレコードを偽装し、正当なパケットを破棄する可能性があります。(CVE-2016-2181)- BIGNUMファイルを処理するときにユーザー指定の入力が不適切に検証されているため、オーバーフロー状態がbn_print.cのBN_bn2dec()関数にあります。認証されていないリモートの攻撃者がこれを悪用し、プロセスをクラッシュさせる可能性があります。(CVE-2016-2182)- 脆弱な64ビットのブロック暗号をデフォルトで使用しているため、3DESとBlowfishのアルゴリズムにSWEET32として知られる脆弱性があります。十分なリソースを持つ中間にいる攻撃者が、「誕生日」攻撃を通じて、この脆弱性を悪用し、固定された秘密情報と既知の平文の間でXORを漏えいする衝突を検出します。これにより、安全なHTTPクッキーなどの秘密のテキストが漏えいし、認証されたセッションの乗っ取りが引き起こされる可能性があります。(CVE-2016-2183)- チケットHMACダイジェストが不適切に処理されるため、t1_lib.cのtls_decrypt_ticket()関数に欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、短すぎるチケットを利用してプログラムをクラッシュさせ、サービス拒否を引き起こす可能性があります。(CVE-2016-6302)- ユーザー指定の入力が不適切に検証されているため、mdc2dgst.cのMDC2_Update()関数に整数オーバーフロー状態があります。認証されていないリモートの攻撃者がこれを悪用して、ヒープベースのバッファオーバーフローを引き起こし、サービス拒否状態を引き起こしたり任意のコードを実行したりする可能性があります。(CVE-2016-6303)- クライアントからの大きすぎるOCSPステータスリクエスト拡張が不適切に処理されているため、t1_lib.cのssl_parse_clienthello_tlsext()関数に欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、大きなOCSPステータスリクエスト拡張を介してメモリリソースを不足させ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-6304)- 証明書解析ツールに領域外読み取りエラーがあり、認証されていないリモートの攻撃者が証明書操作を細工し、サービス拒否状態を引き起こす可能性があります。(CVE-2016-6306)- 暗号化した接続の確立に長期キーが使用されるため、GOST暗号スイートに欠陥があります。中間にいる攻撃者がこれを悪用し、Key Compromise Impersonation(KCI)攻撃によりサーバーになりすます可能性があります。

ソリューション

Tenable SecurityCenterバージョン5.4.1以降にアップグレードしてください。または、パッチについてベンダーにお問い合わせください。

関連情報

https://static.tenable.com/prod_docs/upgrade_security_center.html

https://www.openssl.org/news/secadv/20160922.txt

https://sweet32.info/

https://www.openssl.org/blog/blog/2016/08/24/sweet32/

プラグインの詳細

深刻度: Critical

ID: 101045

ファイル名: securitycenter_openssl_1_0_1u.nasl

バージョン: 1.10

タイプ: combined

エージェント: unix

ファミリー: Misc.

公開日: 2017/6/26

更新日: 2020/10/9

依存関係: securitycenter_installed.nbin, securitycenter_detect.nbin

リスク情報

CVSS スコアのソース: manual

CVSS スコアの根本的理由: Score based on analysis of the vendor advisory.

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.8

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:tenable:securitycenter

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/11/28

脆弱性公開日: 2015/8/10

参照情報

CVE: CVE-2016-2177, CVE-2016-2178, CVE-2016-2179, CVE-2016-2180, CVE-2016-2181, CVE-2016-2182, CVE-2016-2183, CVE-2016-6302, CVE-2016-6303, CVE-2016-6304, CVE-2016-6306

BID: 91081, 91319, 92117, 92557, 92628, 92630, 92982, 92984, 92987, 93150, 93153