Tenable SecurityCenter PHP < 5.6.25の複数の脆弱性(TNS-2016-09)

critical Nessus プラグイン ID 101047
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストのTenable SecurityCenterアプリケーションには、複数の脆弱性の影響を受けるPHPライブラリが含まれています。

説明

リモートホストにインストールされているTenable SecurityCenterアプリケーションには、セキュリティパッチがありません。そのため、PHPのバンドル版にある複数の脆弱性の影響を受けます。-逆シリアル化中にオブジェクトを処理するとき、var_unserializer.cのobject_common2()関数に詳細不明な欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、任意のコードを実行する可能性があります。(CVE-2016-7124)- セッション名を処理する際、session.cに詳細不明な欠陥があります。認証されていないリモートの攻撃者がこれを悪用して、任意のデータをセッションに挿入する可能性があります。(CVE-2016-7125)- 色の数を処理する際、gd_topal.cのselect_colors()関数に整数切り捨ての欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、ヒープベースのバッファオーバーフローを引き起こし、任意のコードを実行する可能性があります。(CVE-2016-7126)- 負のガンマ値を処理する際、gd.cのimagegammacorrect()関数にインデックスの欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、NULLを任意のメモリ位置に書き込み、サービス拒否状態を引き起こしたり、任意のコードを実行したりする可能性があります。(CVE-2016-7127)- TIFFイメージコンテンツを処理する際、exif.cのexif_process_IFD_in_TIFF()関数に欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、メモリコンテンツを漏えいさせる可能性があります。(CVE-2016-7128)- 無効なdateTime値を逆シリアル化する際、wddx.cのphp_wddx_process_data()関数に欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こす可能性があります。(CVE-2016-7129)- Base64バイナリ値を処理する際、wddx.cのphp_wddx_pop_element()関数にNULLポインターデリファレンスの欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こす可能性があります。(CVE-2016-7130)- 無効な XML コンテンツを処理する際、wddx.cのphp_wddx_deserialize_ex()関数にNULLポインターデリファレンスの欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こす可能性があります。(CVE-2016-7131)- 詳細不明なNULLポインターデリファレンスの欠陥がwddx.cのphp_wddx_pop_element()関数にあります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こす可能性があります。(CVE-2016-7132)- snmp.cのphp_snmp_parse_oid()関数に整数オーバーフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、ヒープベースのバッファオーバーフローを引き起こし、任意のコードを実行する可能性があります。- 過剰に長い文字列の処理が不適切なために、ereg.c の sql_regcase() 関数にオーバーフローの状態が存在します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。- 整数オーバーフロー状態が base64.c の php_base64_encode() 関数に存在し、過剰に長い文字列を処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用し、任意のコードを実行する可能性があります。- quot_print.c の php_quot_print_encode() 関数に整数オーバーフロー状態が存在し、過剰に長い文字列を処理する際に発生します。認証されていないリモートの攻撃者は、これを悪用して、ヒープベースのバッファオーバーフロー状態を引き起こし、任意のコードを実行する可能性があります。- var.c の unserialize() 関数に use-after-free エラーが存在します。認証されていないリモートの攻撃者がこれを悪用し、すでに解放されたメモリをデリファレンスして、任意のコードを実行する可能性があります。- ftp_fopen_wrapper.c の php_ftp_fopen_connect() 関数に欠陥が存在し、セキュアな方式をリクエストしている場合でも、中間者攻撃者が通常の FTP に密かにダウングレードすることが可能です。- url.c の php_url_encode() 関数に整数オーバーフロー状態が存在し、過剰に長い文字列を処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。- uuencode.c の php_uuencode() 関数に整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。- bz2.c の bzdecompress() 関数に整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。- interface.c の curl_escape() 関数に整数オーバーフロー状態が存在し、過剰に長いエスケープ付き文字列を処理する際に発生します。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。注意:Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

ソリューション

SecurityCenterバージョン5.4.1以降にアップグレードしてください。または、パッチについてベンダーにお問い合わせください。

関連情報

https://www.tenable.com/security/tns-2016-19

http://php.net/ChangeLog-5.php#5.6.25

プラグインの詳細

深刻度: Critical

ID: 101047

ファイル名: securitycenter_php_5_6_25.nasl

バージョン: 1.8

タイプ: combined

エージェント: unix

ファミリー: Misc.

公開日: 2017/6/26

更新日: 2020/10/9

依存関係: securitycenter_installed.nbin, securitycenter_detect.nbin

リスク情報

CVSS スコアのソース: CVE-2016-7124

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:tenable:securitycenter

必要な KB アイテム: Host/SecurityCenter/Version, installed_sw/SecurityCenter, Host/SecurityCenter/support/php/version

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/11/28

脆弱性公開日: 2016/8/10

参照情報

CVE: CVE-2016-7124, CVE-2016-7125, CVE-2016-7126, CVE-2016-7127, CVE-2016-7128, CVE-2016-7129, CVE-2016-7130, CVE-2016-7131, CVE-2016-7132

BID: 92552, 92564, 92755, 92756, 92757, 92758, 92764, 92767, 92768