Poppler < 0.56.0の複数の脆弱性

high Nessus プラグイン ID 101167

概要

リモートホストにインストールされているパッケージが複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているPopplerのバージョンは、 0.56.0より前です。したがって、以下の複数の脆弱性による影響を受けます:

- ユーザー入力の検証が不適切なために、GfxState.cc内のgetColor()関数にスタックベースのオーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたPDF文書を開くようにユーザーを誘導することでプロセスをクラッシュさせ、サービス拒否の状態を作り出す可能性があります。
(CVE-2017-9775)

ユーザー入力の検証が不適切なため、JBIG2Stream.ccのcombine()関数に整数オーバーフロー状態が存在します。認証されていないリモートの攻撃者がこれらを悪用し、ユーザーを騙して特別に細工されたPDF文書を開かせることで、サービス拒否状態を引き起こしたり、任意のコードを実行したりする可能性があります。
(CVE-2017-9775)

ソリューション

Popplerバージョン0.56.0以降にアップグレードしてください。

関連情報

https://bugs.freedesktop.org/show_bug.cgi?id=101540

https://bugs.freedesktop.org/show_bug.cgi?id=101541

プラグインの詳細

深刻度: High

ID: 101167

ファイル名: poppler_0_56.nasl

バージョン: 1.10

タイプ: local

エージェント: unix, macosx

ファミリー: Misc.

公開日: 2017/6/30

更新日: 2020/4/21

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2017-9776

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:freedesktop:poppler

必要な KB アイテム: Host/local_checks_enabled

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/6/22

脆弱性公開日: 2017/6/20

参照情報

CVE: CVE-2017-9775, CVE-2017-9776

BID: 99240, 99241