Cisco IOS SNMPパケットによるリモートでの複数のバッファオーバーフロー状態のRCE処理(cisco-sa-20170629-snmp)

high Nessus プラグイン ID 101268
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートデバイスに、ベンダーが提供したセキュリティパッチがありません。

説明

自己報告されたバージョンおよび構成によると、リモートデバイスで実行されているCisco IOSソフトウェアは、複数のオーバーフロー状態があるため、Simple Network Management Protocol(SNMP)サブシステムでリモートで複数のコードが実行される脆弱性の影響を受けます。
認証されていないリモートの攻撃者がこの脆弱性を悪用し、特別に細工されたSNMPパケットを介し、任意のコードを実行する可能性があります。

攻撃者がSNMPバージョン2c以前でこれらの脆弱性をエクスプロイトするには、影響を受けたシステムのSNMP読み出し専用のコミュニティストリングが必要です。攻撃者がSNMPバージョン3でこれらの脆弱性をエクスプロイトするには、影響を受けたシステムの資格情報が必要です。

ソリューション

Ciscoセキュリティアドバイザリcisco-sa-20170629-snmpに記載されている該当の修正済みバージョンにアップグレードしてください。または、回避策としてデバイス上の以下のMIBを無効にします。

- ADSL-LINE-MIB
- ALPS-MIB
- CISCO-ADSL-DMT-LINE-MIB
- CISCO-BSTUN-MIB
- CISCO-MAC-AUTH-BYPASS-MIB
- CISCO-SLB-EXT-MIB
- CISCO-VOICE-DNIS-MIB
- CISCO-VOICE-NUMBER-EXPANSION-MIB
- TN3270E-RT-MIB

関連情報

http://www.nessus.org/u?564e08f8

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve54313

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve57697

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve60276

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve60376

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve60402

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve60507

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve66540

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve66601

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve66658

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve78027

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCve89865

プラグインの詳細

深刻度: High

ID: 101268

ファイル名: cisco-sa-20170629-snmp-ios.nasl

バージョン: 1.12

タイプ: combined

ファミリー: CISCO

公開日: 2017/7/7

更新日: 2020/12/1

依存関係: cisco_ios_version.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2017-6744

VPR

リスクファクター: Critical

スコア: 9

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 7

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:cisco:ios

必要な KB アイテム: Host/Cisco/IOS/Version, Settings/ParanoidReport

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2017/6/29

脆弱性公開日: 2017/6/29

参照情報

CVE: CVE-2017-6736, CVE-2017-6737, CVE-2017-6738, CVE-2017-6739, CVE-2017-6740, CVE-2017-6741, CVE-2017-6742, CVE-2017-6743, CVE-2017-6744

BID: 99345