PHP 7.0.x < 7.0.21の複数の脆弱性

critical Nessus プラグイン ID 101526
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは、7.0.21より前の7.0.xです。したがって、次の脆弱性の影響を受けます。- pcre_jit_compile.cファイル内のcompile_bracket_matchingpath()関数でPCREライブラリに、領域外読み取りエラーがあります。認証されていないリモートの攻撃者は、これを悪用し、特別に細工された正規表現を介して、ライブラリにリンクされたプロセスをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。(CVE-2017-6004)- 特別に細工されたGIFファイルを処理するときに、gd_gif_in.cファイル内のgdImageCreateFromGifCtx()関数のGDグラフィックスライブラリ(LibGD)に、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、秘密メモリコンテンツを漏えいさせたり、ライブラリにリンクされたプロセスをクラッシュさせたりする可能性があります。(CVE-2017-7890)- regexec.cファイル内のmatch_at()関数のOnigurumaに、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、秘密メモリコンテンツを漏えいさせたり、ライブラリにリンクされたプロセスをクラッシュさせたりする可能性があります。(CVE-2017-9224)- 正規表現のコンパイル中に、next_state_val()関数のOnigurumaに領域外書き込みエラーがあります。認証されていないリモートの攻撃者がこの脆弱性を悪用し、任意のコードを実行する可能性があります。(CVE-2017-9226)- utf8.cファイル内のmbc_enc_len()関数のOnigurumaに、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、メモリコンテンツを漏えいさせたり、ライブラリにリンクされたプロセスをクラッシュさせたりする可能性があります。(CVE-2017-9227)- 正規表現のコンパイル中に、bitset_set_range()関数のOnigurumaに、領域外書き込みエラーがあります。認証されていないリモートの攻撃者がこの脆弱性を悪用し、任意のコードを実行する可能性があります。(CVE-2017-9228)- 正規表現のコンパイル中に、regexec.cファイル内のleft_adjust_char_head()関数のOnigurumaに、無効なポインター逆参照の欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、ライブラリにリンクされたプロセスをクラッシュさせて、サービス拒否状態を引き起こす可能性があります。(CVE-2017-9229)- 文書化されていない値「-1」が返されるため、crypto/evp/p_seal.cファイル内のEVP_SealInit()関数のOpenSSLに欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、詳細不明な影響を引き起こす可能性があります。(CVE-2017-11144)- ext/date/lib/parse_date.cファイル内のphp_parse_date()関数のPHPに、領域外の読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用して、メモリコンテンツの漏えい、またはサービス拒否状態を引き起こす可能性があります。(CVE-2017-11145)- ロケールの解析をするときに、ユーザーが入力した情報が不適切に検証されているため、msgfmt_parse_message()関数のPHPに、スタックベースのバッファオーバーフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2017-11362)- INI解析APIのPHPに、特にZend/zend_ini_parser.yファイル内のzend_ini_do_op()関数で、ユーザーが入力した情報が不適切に検証されているためにオフバイワン・オーバフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2017-11628)- ext/standard/var_unserializer.re.ファイル内のfinish_nested_data()関数のPHPに、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用して、メモリコンテンツの漏えい、またはサービス拒否状態を引き起こす可能性があります。(CVE-2017-12933)- ext/standard/var_unserializer.c.ファイル内のzval_get_type()関数のPHPに、use-after-freeエラーがあります。認証されていないリモートの攻撃者がこの脆弱性を悪用し、任意のコードを実行する可能性があります。(CVE-2017-12934)注:Nessus はこれらの問題をテストしていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

ソリューション

PHPバージョン7.0.21以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.21

プラグインの詳細

深刻度: Critical

ID: 101526

ファイル名: php_7_0_21.nasl

バージョン: 1.10

タイプ: remote

ファミリー: CGI abuses

公開日: 2017/7/13

更新日: 2020/4/27

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2017-12933

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2017/7/6

脆弱性公開日: 2017/5/17

参照情報

CVE: CVE-2017-6004, CVE-2017-7890, CVE-2017-9224, CVE-2017-9226, CVE-2017-9227, CVE-2017-9228, CVE-2017-9229, CVE-2017-11144, CVE-2017-11145, CVE-2017-11362, CVE-2017-11628, CVE-2017-12933, CVE-2017-12934

BID: 96295, 99489, 99490, 99492, 99501, 100428