SUSE SLES12セキュリティ更新プログラム:xorg-x11-server (SUSE-SU-2017:1861-1)

high Nessus プラグイン ID 101765

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このxorg-x11-serverの更新では、次のセキュリティ問題が修正されます:

- CVE-2017-10971: クライアントによるスタックオーバーフローを防止するため、GenericEventのエンディアン処理を修正します。(bnc#1035283)

- ProcXSendExtensionEventにより送信されるすべてのイベントのタイプが、許容範囲内であるようにします。

- CVE-2017-10972: 情報漏洩を回避するため、xEvent eventTをゼロで初期化します。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

このSUSEセキュリティ更新をインストールするには、YaST online_updateを使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Server for SAP 12:zypper in -t patch SUSE-SLE-SAP-12-2017-1150=1

SUSE Linux Enterprise Server 12-LTSS:zypper in -t patch SUSE-SLE-SERVER-12-2017-1150=1

お使いのシステムを最新の状態にするには、「zypperパッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1035283

https://www.suse.com/security/cve/CVE-2017-10971/

https://www.suse.com/security/cve/CVE-2017-10972/

http://www.nessus.org/u?9bb2e787

プラグインの詳細

深刻度: High

ID: 101765

ファイル名: suse_SU-2017-1861-1.nasl

バージョン: 1.10

タイプ: local

エージェント: unix

公開日: 2017/7/17

更新日: 2021/1/6

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 4.8

ベクトル: AV:N/AC:L/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:xorg-x11-server, p-cpe:/a:novell:suse_linux:xorg-x11-server-debuginfo, p-cpe:/a:novell:suse_linux:xorg-x11-server-debugsource, p-cpe:/a:novell:suse_linux:xorg-x11-server-extra, p-cpe:/a:novell:suse_linux:xorg-x11-server-extra-debuginfo, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/7/14

脆弱性公開日: 2017/7/6

参照情報

CVE: CVE-2017-10971, CVE-2017-10972