Oracle Linux 7:X.org/X11/libraries(ELSA-2017-1865)

critical Nessus プラグイン ID 102340

概要

リモートのOracle Linuxホストに、1つ以上のセキュリティ更新がありません。

説明

出典: Red Hatセキュリティアドバイザリ2017:1865:更新がRed Hat Enterprise Linux 7用に入手可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度中として評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。X11(Xorg)ライブラリは、ライブラリルーチンを提供するもので、すべてのX Windowアプリケーション内で使用されます。次のパッケージが新しいアップストリームバージョンにアップデートされました:libX11 (1.6.5)、libXaw (1.0.13)、libXdmcp (1.1.2)、libXfixes (5.0.3)、libXfont (1.5.2)、libXi (1.7.9)、libXpm (3.5.12)、libXrandr (1.5.1)、libXrender (0.9.10)、libXt (1.1.5)、libXtst (1.2.3)、libXv (1.0.11)、libXvMC (1.0.10)、libXxf86vm (1.1.4)、libdrm (2.4.74)、libepoxy (1.3.1)、libevdev (1.5.6)、libfontenc (1.1.3)、libvdpau (1.1.1)、libwacom (0.24)、libxcb (1.12)、libxkbfile (1.0.9)、mesa (17.0.1)、mesa-private-llvm (3.9.1)、xcb-proto (1.12)、xkeyboard-config (2.20)、xorg-x11-proto-devel (7.7) (BZ#1401667、BZ#1401668、BZ#1401669、BZ#1401670、BZ#1401671、BZ#1401672、BZ#1401673、BZ#1401675、BZ#1401676、BZ#1401677、BZ#1401678、BZ#1401679、BZ#1401680、BZ#1401681、BZ#1401682、BZ#1401683、BZ#1401685、BZ#1401690、BZ#1401752、BZ#1401753、BZ#1401754、BZ#1402560、BZ#1410477、BZ#1411390、BZ#1411392、BZ#1411393、BZ#1411452、BZ#1420224)セキュリティ修正プログラム:* libXpmにヒープベースのバッファオーバーフローにつながる整数オーバーフローの欠陥が見つかりました。攻撃者はこの欠陥を利用して、特別に細工されたXPMファイルを介してlibXpmを使用し、アプリケーションをクラッシュさせる可能性があります。(CVE-2016-10164)* libXdmcpが弱いエントロピーを使用してセッションキーを生成することが発見されました。xdmcpを使用するマルチユーザーシステムでは、ローカルの攻撃者がプロセスリストから入手可能な情報を使用して、総当たり攻撃でキーを探し当て、他のユーザーのセッションを乗っ取る可能性があります。(CVE-2017-2625)* libICEは弱いエントロピーを使用してキーを生成することが発見されました。ローカルの攻撃者はプロセスリストから入手可能な情報を使用して、セッションハイジャックにこの欠陥を使用する可能性があります。(CVE-2017-2626)Red Hatは、CVE-2017-2625とCVE-2017-2626を報告してくれたEric Sesterhenn氏(X41 D-Sec GmbH)に感謝の意を表します。追加の変更:このリリースの変更に関する詳細については、「参照」セクションからリンクされているRed Hat Enterprise Linux 7.4リリースノートを参照してください。

ソリューション

影響を受けるx.orgおよび/またはx11のパッケージを更新してください。

関連情報

https://oss.oracle.com/pipermail/el-errata/2017-August/007109.html

プラグインの詳細

深刻度: Critical

ID: 102340

ファイル名: oraclelinux_ELSA-2017-1865.nasl

バージョン: 3.5

タイプ: local

エージェント: unix

公開日: 2017/8/10

更新日: 2021/1/14

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:oracle:linux:drm-utils, p-cpe:/a:oracle:linux:libICE, p-cpe:/a:oracle:linux:libICE-devel, p-cpe:/a:oracle:linux:libX11, p-cpe:/a:oracle:linux:libX11-common, p-cpe:/a:oracle:linux:libX11-devel, p-cpe:/a:oracle:linux:libXaw, p-cpe:/a:oracle:linux:libXaw-devel, p-cpe:/a:oracle:linux:libXcursor, p-cpe:/a:oracle:linux:libXcursor-devel, p-cpe:/a:oracle:linux:libXdmcp, p-cpe:/a:oracle:linux:libXdmcp-devel, p-cpe:/a:oracle:linux:libXfixes, p-cpe:/a:oracle:linux:libXfixes-devel, p-cpe:/a:oracle:linux:libXfont, p-cpe:/a:oracle:linux:libXfont-devel, p-cpe:/a:oracle:linux:libXfont2, p-cpe:/a:oracle:linux:libXfont2-devel, p-cpe:/a:oracle:linux:libXi, p-cpe:/a:oracle:linux:libXi-devel, p-cpe:/a:oracle:linux:libXpm, p-cpe:/a:oracle:linux:libXpm-devel, p-cpe:/a:oracle:linux:libXrandr, p-cpe:/a:oracle:linux:libXrandr-devel, p-cpe:/a:oracle:linux:libXrender, p-cpe:/a:oracle:linux:libXrender-devel, p-cpe:/a:oracle:linux:libXt, p-cpe:/a:oracle:linux:libXt-devel, p-cpe:/a:oracle:linux:libXtst, p-cpe:/a:oracle:linux:libXtst-devel, p-cpe:/a:oracle:linux:libXv, p-cpe:/a:oracle:linux:libXv-devel, p-cpe:/a:oracle:linux:libXvMC, p-cpe:/a:oracle:linux:libXvMC-devel, p-cpe:/a:oracle:linux:libXxf86vm, p-cpe:/a:oracle:linux:libXxf86vm-devel, p-cpe:/a:oracle:linux:libdrm, p-cpe:/a:oracle:linux:libdrm-devel, p-cpe:/a:oracle:linux:libepoxy, p-cpe:/a:oracle:linux:libepoxy-devel, p-cpe:/a:oracle:linux:libevdev, p-cpe:/a:oracle:linux:libevdev-devel, p-cpe:/a:oracle:linux:libevdev-utils, p-cpe:/a:oracle:linux:libfontenc, p-cpe:/a:oracle:linux:libfontenc-devel, p-cpe:/a:oracle:linux:libinput, p-cpe:/a:oracle:linux:libinput-devel, p-cpe:/a:oracle:linux:libvdpau, p-cpe:/a:oracle:linux:libvdpau-devel, p-cpe:/a:oracle:linux:libvdpau-docs, p-cpe:/a:oracle:linux:libwacom, p-cpe:/a:oracle:linux:libwacom-data, p-cpe:/a:oracle:linux:libwacom-devel, p-cpe:/a:oracle:linux:libxcb, p-cpe:/a:oracle:linux:libxcb-devel, p-cpe:/a:oracle:linux:libxcb-doc, p-cpe:/a:oracle:linux:libxkbcommon, p-cpe:/a:oracle:linux:libxkbcommon-devel, p-cpe:/a:oracle:linux:libxkbcommon-x11, p-cpe:/a:oracle:linux:libxkbcommon-x11-devel, p-cpe:/a:oracle:linux:libxkbfile, p-cpe:/a:oracle:linux:libxkbfile-devel, p-cpe:/a:oracle:linux:mesa-dri-drivers, p-cpe:/a:oracle:linux:mesa-filesystem, p-cpe:/a:oracle:linux:mesa-libEGL, p-cpe:/a:oracle:linux:mesa-libEGL-devel, p-cpe:/a:oracle:linux:mesa-libGL, p-cpe:/a:oracle:linux:mesa-libGL-devel, p-cpe:/a:oracle:linux:mesa-libGLES, p-cpe:/a:oracle:linux:mesa-libGLES-devel, p-cpe:/a:oracle:linux:mesa-libOSMesa, p-cpe:/a:oracle:linux:mesa-libOSMesa-devel, p-cpe:/a:oracle:linux:mesa-libgbm, p-cpe:/a:oracle:linux:mesa-libgbm-devel, p-cpe:/a:oracle:linux:mesa-libglapi, p-cpe:/a:oracle:linux:mesa-libxatracker, p-cpe:/a:oracle:linux:mesa-libxatracker-devel, p-cpe:/a:oracle:linux:mesa-private-llvm, p-cpe:/a:oracle:linux:mesa-private-llvm-devel, p-cpe:/a:oracle:linux:mesa-vulkan-drivers, p-cpe:/a:oracle:linux:vulkan, p-cpe:/a:oracle:linux:vulkan-devel, p-cpe:/a:oracle:linux:vulkan-filesystem, p-cpe:/a:oracle:linux:xcb-proto, p-cpe:/a:oracle:linux:xkeyboard-config, p-cpe:/a:oracle:linux:xkeyboard-config-devel, p-cpe:/a:oracle:linux:xorg-x11-proto-devel, cpe:/o:oracle:linux:7

必要な KB アイテム: Host/local_checks_enabled, Host/OracleLinux, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/8/9

脆弱性公開日: 2017/2/1

参照情報

CVE: CVE-2016-10164, CVE-2017-2625, CVE-2017-2626

RHSA: 2017:1865