Apache Tomcat 8.5.x < 8.5.16の複数の脆弱性

high Nessus プラグイン ID 102589

概要

リモートのApache Tomcatサーバーは、複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているApache Tomcatのバージョンは8.5.16 より前の8.5.xです。したがって、複数の脆弱性の影響を受けます。- HTTP Varyヘッダーが適切に追加されなかったため、CORSフィルターに欠陥があります。これにより、リモートの攻撃者はクライアント側およびサーバー側のキャッシュポイズニング攻撃を行う可能性があります(CVE-2017-7674)- HTTP/2の実装に欠陥があり、ディレクトリトラバーサル攻撃を防ぐ多数のセキュリティチェックをバイパスします。リモートの攻撃者がこれを悪用し、セキュリティ制約をバイパスする可能性があります。(CVE-2017-7675)Nessusはこの問題を利用しておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache Tomcatバージョン8.5.16以降にアップグレードしてください。

参考資料

http://www.nessus.org/u?1f8717dc

プラグインの詳細

深刻度: High

ID: 102589

ファイル名: tomcat_8_5_16.nasl

バージョン: 1.10

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2017/8/18

更新日: 2022/4/11

設定: 徹底したチェックを有効にする

サポートされているセンサー: Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

基本値: 5

現状値: 3.7

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS スコアのソース: CVE-2017-7675

CVSS v3

リスクファクター: High

基本値: 7.5

現状値: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/8/10

脆弱性公開日: 2017/5/16

参照情報

CVE: CVE-2017-7674, CVE-2017-7675

BID: 100256, 100280