Scientific Linux セキュリティ更新: SL7.x x86_64のcurl(20170801)

critical Nessus プラグイン ID 102639
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのScientific Linuxホストに1つ以上のセキュリティ更新プログラムがありません。

説明

セキュリティ修正プログラム:

- curlがデータのエスケープとアンエスケープを処理する方法に、ヒープベースのバッファオーバーフローを引き起こす複数の整数オーバーフローの欠陥が見つかりました。攻撃者がこれらの欠陥を利用して、影響を受けたlibcurl関数に特別に細工された入力を送ることでlibcurlを使用し、アプリケーションをクラッシュさせる可能性があります。(CVE-2016-7167)

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?a121da99

プラグインの詳細

深刻度: Critical

ID: 102639

ファイル名: sl_20170801_curl_on_SL7_x.nasl

バージョン: 3.4

タイプ: local

エージェント: unix

公開日: 2017/8/22

更新日: 2021/1/14

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: Critical

Base Score: 9.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:fermilab:scientific_linux:curl, p-cpe:/a:fermilab:scientific_linux:curl-debuginfo, p-cpe:/a:fermilab:scientific_linux:libcurl, p-cpe:/a:fermilab:scientific_linux:libcurl-devel, x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

パッチ公開日: 2017/8/1

脆弱性公開日: 2016/10/7

参照情報

CVE: CVE-2016-7167