Amazon Linux AMI:libnl3(ALAS-2017-876)

high Nessus プラグイン ID 102864
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのAmazon Linux AMIホストに、セキュリティ更新プログラムがありません。

説明

nlmsg_reserve()の整数オーバーフロー:ヒープバッファオーバーフローにつながる整数オーバーフローがlibnlライブラリで見つかりました。攻撃者はこの欠陥を利用して、libnlでコンパイルされたアプリケーションをクラッシュさせたり、そうしたアプリケーションを実行しているユーザーのコンテキストで任意のコードを実行したりする可能性があります。(CVE-2017-0553)

ソリューション

「yum update libnl3」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/ALAS-2017-876.html

プラグインの詳細

深刻度: High

ID: 102864

ファイル名: ala_ALAS-2017-876.nasl

バージョン: 3.5

タイプ: local

エージェント: unix

公開日: 2017/9/1

更新日: 2018/9/4

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.6

ベクトル: AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS v3

リスクファクター: High

Base Score: 7

ベクトル: CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:amazon:linux:libnl3, p-cpe:/a:amazon:linux:libnl3-cli, p-cpe:/a:amazon:linux:libnl3-debuginfo, p-cpe:/a:amazon:linux:libnl3-devel, p-cpe:/a:amazon:linux:libnl3-doc, cpe:/o:amazon:linux

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

パッチ公開日: 2017/8/30

参照情報

CVE: CVE-2017-0553

ALAS: 2017-876