Tenable SecurityCenter PHP < 5.6.31の複数の脆弱性(TNS-2017-12)

critical Nessus プラグイン ID 103121
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストのTenable SecurityCenterアプリケーションには、複数の脆弱性の影響を受けるPHPライブラリが含まれています。

説明

リモートホストにインストールされているTenable SecurityCenterアプリケーションには、セキュリティパッチがありません。したがって、バンドル化されたバージョンのPHPにある複数の脆弱性の影響を受けます。-ファイルpcre_jit_compile.c内のcompile_bracket_matchingpath()関数のPCREライブラリに領域外読み取りエラーがあります。認証されていないリモートの攻撃者は、これを悪用し、特別に細工された正規表現を介して、ライブラリにリンクされたプロセスをクラッシュさせ、サービス拒否状態を引き起こす可能性があります。(CVE-2017-6004)- 特別に細工されたGIFファイルを処理するときに、gd_gif_in.cファイル内のgdImageCreateFromGifCtx()関数のGDグラフィックスライブラリ(LibGD)に、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、秘密メモリコンテンツを漏えいさせたり、ライブラリにリンクされたプロセスをクラッシュさせたりする可能性があります。(CVE-2017-7890)- regexec.cファイル内のmatch_at()関数のOnigurumaに、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、秘密メモリコンテンツを漏えいさせたり、ライブラリにリンクされたプロセスをクラッシュさせたりする可能性があります。(CVE-2017-9224)- 正規表現のコンパイル中に、next_state_val()関数のOnigurumaに領域外書き込みエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、任意のコードを実行する可能性があります。(CVE-2017-9226)- utf8.cファイル内のmbc_enc_len()関数のOnigurumaに、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、メモリコンテンツを漏えいさせたり、ライブラリにリンクされたプロセスをクラッシュさせたりする可能性があります。(CVE-2017-9227)- 正規表現のコンパイル中に、bitset_set_range()関数のOnigurumaに、領域外書き込みエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、任意のコードを実行する可能性があります。(CVE-2017-9228)- 正規表現のコンパイル中に、regexec.cファイル内のleft_adjust_char_head()関数のOnigurumaに、無効なポインター逆参照の欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、ライブラリにリンクされたプロセスをクラッシュさせて、サービス拒否状態を引き起こす可能性があります。(CVE-2017-9229)- 大きすぎるPOSTリクエストを処理するときに、サービス拒否状態がPHPにあります。認証されていないリモートの攻撃者がこれを悪用し、CPUリソースの過剰消費を引き起こす可能性があります。(CVE-2017-11142)- 空のブールタグを解析するとき、ext/wddx/wddx.cファイル内のphp_wddx_push_element()関数のPHPに、拡張無効フリーエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こす可能性があります。(CVE-2017-11143)- 文書化されていない値「-1」が返されるため、crypto/evp/p_seal.cファイル内のEVP_SealInit()関数のOpenSSLに欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、詳細不明な影響を引き起こす可能性があります。(CVE-2017-11144)- ext/date/lib/parse_date.cファイル内のphp_parse_date()関数のPHPに、領域外の読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、メモリコンテンツの漏えい、またはサービス拒否状態を引き起こす可能性があります。(CVE-2017-11145)- ext/standard/var_unserializer.re.ファイル内のfinish_nested_data()関数のPHPに、領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、メモリコンテンツの漏えい、またはサービス拒否状態を引き起こす可能性があります。Iユーザー指定の入力が不適切に検証されているため、NI解析APIのPHP、特にZend/zend_ini_parser.yファイル内のzend_ini_do_op()関数で、オフバイワン・オーバフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。- 信頼されていないデータの非シリアル化中にfinish_nested_dataのヒープバッファオーバーリードの欠陥があり、PHPの整合性に詳細不明な影響を与える可能性があります。(CVE-2017-12933)- Zend/zend_ini_parser.cのzend_ini_do_op()関数にスタックベースのバッファオーバーフローがあり、サービス拒否またはコード実行を引き起こす可能性があります。(CVE-2017-11628)Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

ベンダーのアドバイザリに記載されている関連パッチを適用してください。

関連情報

https://www.tenable.com/security/tns-2017-12

http://php.net/ChangeLog-5.php#5.6.31

https://support.tenable.com/support-center/index.php?x=&mod_id=160

プラグインの詳細

深刻度: Critical

ID: 103121

ファイル名: securitycenter_php_5_6_31.nasl

バージョン: 1.9

タイプ: combined

エージェント: unix

ファミリー: Misc.

公開日: 2017/9/12

更新日: 2020/10/9

依存関係: securitycenter_installed.nbin, securitycenter_detect.nbin

リスク情報

CVSS スコアのソース: CVE-2017-9224

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:tenable:securitycenter

必要な KB アイテム: Host/SecurityCenter/Version, installed_sw/SecurityCenter, Host/SecurityCenter/support/php/version

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/9/11

脆弱性公開日: 2017/7/10

参照情報

CVE: CVE-2017-6004, CVE-2017-7890, CVE-2017-9224, CVE-2017-9226, CVE-2017-9227, CVE-2017-9228, CVE-2017-9229, CVE-2017-11142, CVE-2017-11143, CVE-2017-11144, CVE-2017-11145, CVE-2017-11628, CVE-2017-12933

BID: 96295, 99489, 99490, 99492, 99501, 99550, 99553, 99601, 99605, 100320, 100538, 101244