openSUSE Security Update : xen (openSUSE-2017-1071)

high Nessus プラグイン ID 103291

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

xenのこの更新は、いくつかの問題を修正します。

これらのセキュリティの問題が修正されました:

- CVE-2017-14316: 内部配列に対する関数「alloc_heap_pages」でバインドチェックが欠落している、攻撃者が細工されたハイパーコールを使用して、Xen内で任意のコードを実行できる可能性がありました(XSA-231、bsc#1056278)

- CVE-2017-14318: __gnttab_cache_flush関数ではグラントテーブルのチェックが欠落していました。これにより、悪意のあるゲストがホストをクラッシュしたり、x86 PVゲストが権限を昇格できる可能性があります(XSA-232、 bsc#1056280)

- CVE-2017-14317: cxenstoredでの競合が原因で二重解放が引き起こされる可能性があります。これにより、xenstoredデーモンのDoSが発生する可能性があります(XSA-233、bsc#1056281)。

- CVE-2017-14319: 付与マッピングの処理中のエラーにより、悪意のあるx86 PVゲストまたはバグのあるx86 PVゲストが、その権限を昇格したり、ハイパーバイザーをクラッシュしたりすることが可能でした(XSA-234、bsc#1056282)。

以下のセキュリティ以外の問題が、修正されました。

- bsc#1057358:セキュアブートでのSUSE Linux Enterprise 12.3の起動を修正しました

- bsc#1055695:バルーン化されたdomUsに対するHVMゲストの更新の復元修正しました

この更新はSUSEからインポートされました:SLE-12-SP3: 更新プロジェクトを更新します。

ソリューション

影響を受けるxenパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1027519

https://bugzilla.opensuse.org/show_bug.cgi?id=1055695

https://bugzilla.opensuse.org/show_bug.cgi?id=1057358

https://bugzilla.opensuse.org/show_bug.cgi?id=1056278

https://bugzilla.opensuse.org/show_bug.cgi?id=1056280

https://bugzilla.opensuse.org/show_bug.cgi?id=1056281

https://bugzilla.opensuse.org/show_bug.cgi?id=1056282

プラグインの詳細

深刻度: High

ID: 103291

ファイル名: openSUSE-2017-1071.nasl

バージョン: 3.5

タイプ: local

エージェント: unix

公開日: 2017/9/18

更新日: 2021/1/19

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.5

CVSS v2

リスクファクター: High

Base Score: 7.2

ベクトル: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3

リスクファクター: High

Base Score: 8.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

脆弱性情報

CPE: cpe:2.3:o:novell:opensuse:42.3:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-doc-html:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-libs:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-libs-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools-domu:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:xen-tools-domu-debuginfo:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

パッチ公開日: 2017/9/17

参照情報

CVE: CVE-2017-14316, CVE-2017-14317, CVE-2017-14318, CVE-2017-14319