FreeBSD: php-gdとgd -- 初期化されていないメモリへのバッファオーバーリード(5033e2fc-98ec-4ef5-8e0b-87cfbbc73081)

medium Nessus プラグイン ID 103478

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのFreeBSDホストに1つ以上のセキュリティ関連の更新プログラムがありません。

説明

PHP開発者による報告:

PHPの5.6.31より前と7.1.7より前の7.xで使用されていた、GDグラフィックスライブラリ(別名libgd)のgd_gif_in.c内のGIFデコード関数gdImageCreateFromGifCtxは、使用前にcolorMap配列をゼロにしません。特別に細工されたGIF画像は、初期化されていないテーブルを使用してスタックの先頭から最大700バイトを読み取り、秘密情報を漏洩する可能性があります。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://bugs.php.net/bug.php?id=74435

http://www.nessus.org/u?eee2795d

プラグインの詳細

深刻度: Medium

ID: 103478

ファイル名: freebsd_pkg_5033e2fc98ec4ef58e0b87cfbbc73081.nasl

バージョン: 3.4

タイプ: local

公開日: 2017/9/27

更新日: 2021/1/4

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3

リスクファクター: Medium

Base Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

脆弱性情報

CPE: p-cpe:/a:freebsd:freebsd:libgd, p-cpe:/a:freebsd:freebsd:php70-gd, p-cpe:/a:freebsd:freebsd:php71-gd, cpe:/o:freebsd:freebsd

必要な KB アイテム: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

パッチ公開日: 2017/9/26

脆弱性公開日: 2017/8/2

参照情報

CVE: CVE-2017-7890