Apache 2.4.x < 2.4.28 HTTPの脆弱性(OptionsBleed)

high Nessus プラグイン ID 103838
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストで実行しているApacheのバージョンは、2.4.28より前の2.4.xです。したがって、.htaccessファイルの<Limit {method}>ディレクティブに関連するHTTPの脆弱性の影響を受けます。

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apacheバージョン2.4.28以降にアップグレードしてください。

関連情報

https://archive.apache.org/dist/httpd/CHANGES_2.4.28

https://httpd.apache.org/security/vulnerabilities_24.html

プラグインの詳細

深刻度: High

ID: 103838

ファイル名: apache_2_4_28.nasl

バージョン: 1.9

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2017/10/13

更新日: 2021/1/28

依存関係: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2017-9798

VPR

リスクファクター: Medium

スコア: 6.1

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

必要な KB アイテム: installed_sw/Apache

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2017/10/5

脆弱性公開日: 2017/9/18

参照情報

CVE: CVE-2017-9798

BID: 100872