SUSE SLES11セキュリティ更新プログラム:ImageMagick(SUSE-SU-2017:3168-1)

critical Nessus プラグイン ID 104966

Language:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このImageMagickの更新では、いくつかの問題を修正しています。これらのセキュリティの問題が修正されました:

- CVE-2017-11534:細工されたファイルをconvertで処理すると、coders/wmf.cのlite_font_map()関数でメモリリークが発生する可能性がありました(bsc#1050135)。

- CVE-2017-13133:coders/xcf.cのload_level関数にオフセット検証がないため、攻撃者が細工されたファイルを介してサービス拒否(load_tileメモリの枯渇)を引き起こすことが可能でした(bsc#1055219)。

- CVE-2017-13139:coders/png.cのReadOneMNGImage関数に、MNG CLIPチャンクの領域外読み取りがありました(bsc#1055430)。

- CVE-2017-15033:coders/yuv.cのReadYUVImageにおけるメモリリークが修正されました(bsc#1061873)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaST online_updateを使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise2ソフトウェア開発キット 11-SP4:zypper in -t patch sdksp4-ImageMagick-13356=1

SUSE Linux Enterprise Server 11-SP4:zypper in -t patch slessp4-ImageMagick-13356=1

SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch dbgsp4-ImageMagick-13356=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

参考資料

https://bugzilla.suse.com/show_bug.cgi?id=1050135

https://bugzilla.suse.com/show_bug.cgi?id=1055219

https://bugzilla.suse.com/show_bug.cgi?id=1055430

https://bugzilla.suse.com/show_bug.cgi?id=1061873

https://www.suse.com/security/cve/CVE-2017-11534/

https://www.suse.com/security/cve/CVE-2017-13133/

https://www.suse.com/security/cve/CVE-2017-13139/

https://www.suse.com/security/cve/CVE-2017-15033/

http://www.nessus.org/u?76a92e80

プラグインの詳細

深刻度: Critical

ID: 104966

ファイル名: suse_SU-2017-3168-1.nasl

バージョン: 3.9

タイプ: local

エージェント: unix

公開日: 2017/12/1

更新日: 2021/1/19

サポートされているセンサー: Frictionless Assessment Azure, Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libmagickcore1, cpe:/o:novell:suse_linux:11

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/rpm-list, Host/cpu, Host/SuSE/release

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/11/30

脆弱性公開日: 2017/7/23

参照情報

CVE: CVE-2017-11534, CVE-2017-13133, CVE-2017-13139, CVE-2017-15033