PHP 5.6.x < 5.6.33の複数の脆弱性

medium Nessus プラグイン ID 105771
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは、5.6.33より前の5.6.xです。したがって、以下の複数の脆弱性による影響を受けます:- gdImageCreateFromGifCtxの潜在的な無限ループ。(CVE-2018-5711)- ユーザー指定の入力をユーザーに返す前に不適切に検証しているため、.phar 404ページの反射型XSSの脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたURLをクリックするようユーザーを誘導して、ユーザーのブラウザーセッションで任意のスクリプトコードを実行する可能性があります。(CVE-2018-5712)Nessusはこの問題をテストしてしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

PHPバージョン5.6.33以降にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.6.33

プラグインの詳細

深刻度: Medium

ID: 105771

ファイル名: php_5_6_33.nasl

バージョン: 1.9

タイプ: remote

ファミリー: CGI abuses

公開日: 2018/1/12

更新日: 2019/11/8

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2018-5712

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/1/4

脆弱性公開日: 2018/1/4

参照情報

CVE: CVE-2018-5711, CVE-2018-5712