PHP 7.0.x < 7.0.27の複数の脆弱性

medium Nessus プラグイン ID 105772
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは、7.0.27より前の7.0.xです。したがって、以下の脆弱性の影響を受けます。- 整数の符号付きエラーにより、GDグラフィックライブラリ(libgd)内のgd_gif_in.cスクリプトのimagecreatefromgifおよびimagecreatefromstring関数にサービス拒否(DoS)の脆弱性が存在します。認証されていないリモートの攻撃者がこの問題を悪用し、細工されたGIFファイルを介してアプリケーションの応答を停止させる可能性があります。(CVE-2018-5711)- .pharファイルがユーザーに返される前に不適切に検証されているため、クロスサイトスクリプティング(XSS)の脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたURLをクリックするようユーザーを誘導して、ユーザーのブラウザーセッションで任意のスクリプトコードを実行する可能性があります。(CVE-2018-5712)-atoi呼び出しでhttp_header_valueがNULL値である可能性があるため、ext/standard/http_fopen_wrapper.cスクリプトにサービス拒否(DoS)の脆弱性が存在します。認証されていないリモートの攻撃者がこの問題を悪用し、特別に細工されたHTTP応答を介してアプリケーションの応答を停止させる可能性があります。(CVE-2018-14884)注:Nessus はこれらの問題をテストしていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

ソリューション

PHPバージョン7.0.27以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.27

プラグインの詳細

深刻度: Medium

ID: 105772

ファイル名: php_7_0_27.nasl

バージョン: 1.9

タイプ: remote

ファミリー: CGI abuses

公開日: 2018/1/12

更新日: 2019/11/8

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2018-5712

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/1/4

脆弱性公開日: 2018/1/4

参照情報

CVE: CVE-2018-5711, CVE-2018-5712, CVE-2018-14884

BID: 102742, 102743, 104968