openSUSE Security Update : libevent (openSUSE-2018-95)

critical Nessus プラグイン ID 106363

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

このlibeventの更新では、以下のセキュリティ問題を修正します:

- CVE-2016-10195:DNSリモートスタックオーバーリードの脆弱性(bsc#1022917)

- CVE-2016-10196:evutil_parse_sockaddr_port()でのスタック/バッファオーバーフロー(bsc#1022918)

- CVE-2016-10197:search_make_new()での領域外読み取り(bsc#1022919)

この更新はSUSEからインポートされました:SLE-12:更新プロジェクトを更新します。

ソリューション

影響を受けるlibeventパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1022917

https://bugzilla.opensuse.org/show_bug.cgi?id=1022918

https://bugzilla.opensuse.org/show_bug.cgi?id=1022919

プラグインの詳細

深刻度: Critical

ID: 106363

ファイル名: openSUSE-2018-95.nasl

バージョン: 3.3

タイプ: local

エージェント: unix

公開日: 2018/1/26

更新日: 2021/1/19

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: Critical

Base Score: 9.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

脆弱性情報

CPE: cpe:2.3:o:novell:opensuse:42.2:*:*:*:*:*:*:*, cpe:2.3:o:novell:opensuse:42.3:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libevent-2_0-5:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libevent-2_0-5-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libevent-2_0-5-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libevent-2_0-5-debuginfo-32bit:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libevent-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:libevent-devel:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

パッチ公開日: 2018/1/25

参照情報

CVE: CVE-2016-10195, CVE-2016-10196, CVE-2016-10197