PHP 7.0.x < 7.0.28のスタックバッファオーバーフロー

critical Nessus プラグイン ID 107217

概要

リモートのWebサーバーで実行されているPHPのバージョンは、スタックバッファオーバーフローの脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは7.0.28より前の7.0.xです。したがって、バッファオーバーフローの脆弱性の影響を受けます。

ソリューション

PHPバージョン7.0.28以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.28

http://www.nessus.org/u?77aa0aa0

プラグインの詳細

深刻度: Critical

ID: 107217

ファイル名: php_7_0_28.nasl

バージョン: 1.6

タイプ: remote

ファミリー: CGI abuses

公開日: 2018/3/8

更新日: 2022/4/11

リスク情報

CVSS スコアのソース: CVE-2018-7584

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/3/1

脆弱性公開日: 2018/3/1

参照情報

CVE: CVE-2018-7584