openSUSE Security Update : ntp (openSUSE-2018-376)

critical Nessus プラグイン ID 109102

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

ntp用のこの更新プログラムでは、以下の問題が修正されています:

- 4.2.8p11への更新(bsc#1082210):

- CVE-2016-1549:Sybilの脆弱性:エフェメラル関連付け攻撃。ntp-4.2.8p7で修正済みですが、4.2.8p11ではこの問題に対する重要な保護が追加されています。

- CVE-2018-7182:ctl_getitem():バッファ読み込みオーバーランにより、未定義の動作や情報漏洩が発生します
(bsc#1083426)

- CVE-2018-7170:複数の認証エフェメラル関連付け。(bsc#1083424)

- CVE-2018-7184:インターリーブ対称モードが不適切な状態から回復できません(bsc#1083422)

- CVE-2018-7185:認証されていないパケットにより、認証されたインターリーブされた関連付けがリセットされる可能性があります(bsc#1083420)

- CVE-2018-7183:ntpq:decodearr()がバッファ制限を超えて書き込む可能性があります(bsc#1083417)

- sntpで、libeventのキャッシュされたタイムスタンプを使用しません。
(bsc#1077445)

この更新はSUSEからインポートされました:SLE-12-SP1:更新プロジェクトを更新します。

ソリューション

影響を受けるntpパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1083424

https://bugzilla.opensuse.org/show_bug.cgi?id=1077445

https://bugzilla.opensuse.org/show_bug.cgi?id=1082063

https://bugzilla.opensuse.org/show_bug.cgi?id=1082210

https://bugzilla.opensuse.org/show_bug.cgi?id=1083417

https://bugzilla.opensuse.org/show_bug.cgi?id=1083420

https://bugzilla.opensuse.org/show_bug.cgi?id=1083422

https://bugzilla.opensuse.org/show_bug.cgi?id=1083426

プラグインの詳細

深刻度: Critical

ID: 109102

ファイル名: openSUSE-2018-376.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2018/4/18

更新日: 2021/1/19

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:novell:opensuse:42.3:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:ntp:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:ntp-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:opensuse:ntp-debugsource:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/4/17

参照情報

CVE: CVE-2016-1549, CVE-2018-7170, CVE-2018-7182, CVE-2018-7183, CVE-2018-7184, CVE-2018-7185