SUSE SLES11セキュリティ更新プログラム:python(SUSE-SU-2018:1786-1)

medium Nessus プラグイン ID 110685

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

pythonのこの更新プログラムでは、以下の問題が修正されています:次のセキュリティ脆弱性に対処しました:

- 少なくとも1つのチャネルが提供されていることを検証するチェックをLib/wave.pyに追加します。これより前に、細工したwav形式のオーディオファイルを介して、攻撃者がサービス拒否を引き起こす可能性がありました。 [bsc#1083507、CVE-2017-18207]

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Software Development Kit 11-SP4:zypper in -t patch sdksp4-python-13672=1

SUSE Linux Enterprise Server 11-SP4:zypper in -t patch slessp4-python-13672=1

SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch dbgsp4-python-13672=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1083507

https://www.suse.com/security/cve/CVE-2017-18207/

http://www.nessus.org/u?384adaed

プラグインの詳細

深刻度: Medium

ID: 110685

ファイル名: suse_SU-2018-1786-1.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2018/6/25

更新日: 2021/1/19

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3

リスクファクター: Medium

Base Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libpython2_6, p-cpe:/a:novell:suse_linux:libpython2_6-1_0, p-cpe:/a:novell:suse_linux:python, p-cpe:/a:novell:suse_linux:python-base, p-cpe:/a:novell:suse_linux:python-curses, p-cpe:/a:novell:suse_linux:python-demo, p-cpe:/a:novell:suse_linux:python-gdbm, p-cpe:/a:novell:suse_linux:python-idle, p-cpe:/a:novell:suse_linux:python-tk, p-cpe:/a:novell:suse_linux:python-xml, cpe:/o:novell:suse_linux:11

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

パッチ公開日: 2018/6/22

脆弱性公開日: 2018/3/1

参照情報

CVE: CVE-2017-18207