RHEL 7:mariadb(RHSA-2018:2439)

high Nessus プラグイン ID 111802
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

mariadbの更新プログラムが、Red Hat Enterprise Linux 7で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度中と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。MariaDBは、MySQLとバイナリ相互性のあるマルチユーザーかつマルチスレッドSQLデータベースサーバーです。次のパッケージが新しいアップストリームバージョンにアップデートされました:mariadb(5.5.60)(BZ#1584668、BZ#1584671、BZ#1584674、BZ#1601085)セキュリティ修正プログラム:* mysql:クライアントプログラムの詳細不明な脆弱性(2017年7月CPU)(CVE-2017-3636)* mysql:サーバー:DMLの詳細不明な脆弱性(2017年7月CPU)(CVE-2017-3641)* mysql:クライアントmysqldumpの詳細不明な脆弱性(2017年7月CPU)(CVE-2017-3651)* mysql:サーバー:レプリケーションの詳細不明な脆弱性(2017年10月CPU)(CVE-2017-10268)* mysql:サーバー:オプティマイザーの詳細不明な脆弱性(2017年10月CPU)(CVE-2017-10378)* mysql:クライアントプログラムの詳細不明な脆弱性(2017年10月CPU)(CVE-2017-10379)* mysql:サーバー:DDLの詳細不明な脆弱性(2017年10月CPU)(CVE-2017-10384)* mysql:サーバー:パーティションの詳細不明な脆弱性(2018年1月CPU)(CVE-2018-2562)*mysql:サーバー:DDLの詳細不明な脆弱性(2018年1月CPU)(CVE-2018-2622)* mysql:サーバー:オプティマイザーの詳細不明な脆弱性(2018年1月CPU)(CVE-2018-2640)* mysql:サーバー:オプティマイザーの詳細不明な脆弱性(2018年1月CPU)(CVE-2018-2665)* mysql:サーバー:オプティマイザーの詳細不明な脆弱性(2018年1月CPU)(CVE-2018-2668)* mysql:サーバー:レプリケーションの詳細不明な脆弱性(2018年4月CPU)(CVE-2018-2755)* mysql:クライアントプログラムの詳細不明な脆弱性(2018年4月CPU)(CVE-2018-2761)*mysql:サーバー:ロックの詳細不明な脆弱性(2018年4月CPU)(CVE-2018-2771)* mysql:サーバー:オプティマイザーの詳細不明な脆弱性(2018年4月CPU)(CVE-2018-2781)* mysql:サーバー:DDLの詳細不明な脆弱性(2018年4月CPU)(CVE-2018-2813)* mysql:サーバー:DDLの詳細不明な脆弱性(2018年4月CPU)(CVE-2018-2817)* mysql:InnoDBの詳細不明な脆弱性(2018年4月CPU)(CVE-2018-2819)* mysql:サーバー:DDLの詳細不明な脆弱性(2017年7月CPU)(CVE-2017-3653)* mysql:libmysqldでSSL/TLS not enforcedの使用 (BACKRONYMの再発)(CVE-2018-2767)影響、CVSSスコア、その他の関連情報を含むセキュリティの問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。バグ修正プログラム:* 以前は、mysqladminツールは、リッスンするソケットが特定の方法で応答しないと、不適切な時間待機していました。その結果、MariaDBサーバーの起動中にソケットが使用されるとき、mariadbのサービスが長時間応答停止に陥りました。この更新プログラムでは、mysqladminのタイムアウトが2秒に短縮されました。結果として、mariadbのサービスが開始しても、失敗しても前述の状況でハングアップすることはなくなりました。(BZ#1584023)

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2018:2439

https://access.redhat.com/security/cve/cve-2017-3636

https://access.redhat.com/security/cve/cve-2017-3641

https://access.redhat.com/security/cve/cve-2017-3651

https://access.redhat.com/security/cve/cve-2017-3653

https://access.redhat.com/security/cve/cve-2017-10268

https://access.redhat.com/security/cve/cve-2017-10378

https://access.redhat.com/security/cve/cve-2017-10379

https://access.redhat.com/security/cve/cve-2017-10384

https://access.redhat.com/security/cve/cve-2018-2562

https://access.redhat.com/security/cve/cve-2018-2622

https://access.redhat.com/security/cve/cve-2018-2640

https://access.redhat.com/security/cve/cve-2018-2665

https://access.redhat.com/security/cve/cve-2018-2668

https://access.redhat.com/security/cve/cve-2018-2755

https://access.redhat.com/security/cve/cve-2018-2761

https://access.redhat.com/security/cve/cve-2018-2767

https://access.redhat.com/security/cve/cve-2018-2771

https://access.redhat.com/security/cve/cve-2018-2781

https://access.redhat.com/security/cve/cve-2018-2813

https://access.redhat.com/security/cve/cve-2018-2817

https://access.redhat.com/security/cve/cve-2018-2819

https://access.redhat.com/security/cve/cve-2018-3133

https://access.redhat.com/security/cve/cve-2019-2455

プラグインの詳細

深刻度: High

ID: 111802

ファイル名: redhat-RHSA-2018-2439.nasl

バージョン: 1.10

タイプ: local

エージェント: unix

公開日: 2018/8/17

更新日: 2019/10/24

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.5

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: AV:N/AC:L/Au:S/C:N/I:P/A:C

CVSS v3

リスクファクター: High

Base Score: 7.7

ベクトル: CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:mariadb, p-cpe:/a:redhat:enterprise_linux:mariadb-bench, p-cpe:/a:redhat:enterprise_linux:mariadb-debuginfo, p-cpe:/a:redhat:enterprise_linux:mariadb-devel, p-cpe:/a:redhat:enterprise_linux:mariadb-embedded, p-cpe:/a:redhat:enterprise_linux:mariadb-embedded-devel, p-cpe:/a:redhat:enterprise_linux:mariadb-libs, p-cpe:/a:redhat:enterprise_linux:mariadb-server, p-cpe:/a:redhat:enterprise_linux:mariadb-test, cpe:/o:redhat:enterprise_linux:7, cpe:/o:redhat:enterprise_linux:7.5, cpe:/o:redhat:enterprise_linux:7.6, cpe:/o:redhat:enterprise_linux:7.7

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

パッチ公開日: 2018/8/16

脆弱性公開日: 2017/8/8

参照情報

CVE: CVE-2017-10268, CVE-2017-10378, CVE-2017-10379, CVE-2017-10384, CVE-2017-3636, CVE-2017-3641, CVE-2017-3651, CVE-2017-3653, CVE-2018-2562, CVE-2018-2622, CVE-2018-2640, CVE-2018-2665, CVE-2018-2668, CVE-2018-2755, CVE-2018-2761, CVE-2018-2767, CVE-2018-2771, CVE-2018-2781, CVE-2018-2813, CVE-2018-2817, CVE-2018-2819, CVE-2018-3133, CVE-2019-2455

RHSA: 2018:2439