Apache Struts 2.x < 2.3.16.2の複数のClassLoader操作の脆弱性(S2-021)

high Nessus プラグイン ID 117457

概要

リモートホストで実行されているWebアプリケーションは、複数のClassLoader操作の脆弱性の影響を受けるJavaフレームワークを使用しています。

説明

リモートホストで実行されているApache Strutsのバージョンは、2.3.16.2より前の2.xです。したがって、複数のClassLoaderの脆弱性の影響を受けます。注意:Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

ソリューション

Apache Strutsバージョン2.3.16.2以降にアップグレードしてください

関連情報

http://www.nessus.org/u?736174c4

プラグインの詳細

深刻度: High

ID: 117457

ファイル名: struts_2_3_16_2.nasl

バージョン: 1.12

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Misc.

公開日: 2018/9/12

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.2

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:F/RL:OF/RC:C

CVSS スコアのソース: CVE-2014-0113

CVSS v3

リスクファクター: High

Base Score: 7.3

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

現状ベクトル: E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:struts

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2014/4/24

脆弱性公開日: 2014/4/24

エクスプロイト可能

Metasploit (Apache Struts ClassLoader Manipulation Remote Code Execution)

Elliot (Apache-Struts DefaultActionMapper < 2.3.15.1 RCE Linux)

参照情報

CVE: CVE-2014-0112, CVE-2014-0113

BID: 61189, 61196