PHP 5.6.x < 5.6.38のTransfer-Encoding Parameter XSSの脆弱性

medium Nessus プラグイン ID 117497

概要

リモートのWebサーバーで実行されているPHPのバージョンは、クロスサイトスクリプティングの脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは5.6.38より前の5.6.xです。したがって、クロスサイトスクリプティングの脆弱性による影響を受けます。攻撃者がこの脆弱性を利用して、影響を受けるサイトのセキュリティコンテキスト内で実行される悪意のあるコードを挿入する可能性があります。

ソリューション

PHPバージョン5.6.38以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.6.38

https://bugs.php.net/bug.php?id=76582

プラグインの詳細

深刻度: Medium

ID: 117497

ファイル名: php_5_6_38.nasl

バージョン: 1.8

タイプ: remote

ファミリー: CGI abuses

公開日: 2018/9/14

更新日: 2022/4/11

リスク情報

CVSS スコアのソース: CVE-2018-17082

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP, installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/9/13

脆弱性公開日: 2018/9/13

参照情報

CVE: CVE-2018-17082