Apache ActiveMQ 5.x < 5.14.0のActiveMQ Fileserver Webアプリケーションのリモートコード実行(Xbash)

critical Nessus プラグイン ID 117601
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストで、リモートでコードが実行される脆弱性の影響を受けるWebアプリケーションが実行されています。

説明

リモートホストで実行されているApache ActiveMQのバージョンは、5.14.0より前の5.xです。したがって、リモートでコードが実行される脆弱性による影響を受けます。Fileserver Webアプリケーションでは、リモートの攻撃者が任意のファイルをアップロードしたり実行したりする可能性があります。

ソリューション

Apache ActiveMQをバージョン5.14.0以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?2581a08b

プラグインの詳細

深刻度: Critical

ID: 117601

ファイル名: activemq_5_14_0.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2018/9/19

更新日: 2019/4/5

依存関係: activemq_web_console_detect.nasl

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2016-3088

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.2

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:F/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.1

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:activemq

必要な KB アイテム: installed_sw/ActiveMQ, Settings/ParanoidReport

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/8/8

脆弱性公開日: 2016/6/1

エクスプロイト可能

Metasploit (ActiveMQ web shell upload)

参照情報

CVE: CVE-2016-3088

BID: 90827