Sendmail < 8.12.10 の prescan() 機能のリモートオーバーフロー

critical Nessus プラグイン ID 11838
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートメールサーバーは、複数のバッファオーバーフロー攻撃に脆弱です。

説明

バージョン番号によると、リモート sendmail サーバーは、5.79 と 8.12.9 の間です。このようなバージョンは、報告されているところによれば、リモートバッファオーバーフロー攻撃に対して脆弱であり、1 つは「prescan()」機能、他はそのルールセットの処理に関連するものです。リモートユーザーは、これらの問題を利用して、root 権限を得ることができる場合があります。

ソリューション

Sendmail バージョン 8.12.10 または以降にアップグレードしてください。

関連情報

https://seclists.org/fulldisclosure/2003/Sep/857

プラグインの詳細

深刻度: Critical

ID: 11838

ファイル名: sendmail_prescan_overflow.nasl

バージョン: 1.38

タイプ: remote

ファミリー: SMTP problems

公開日: 2003/9/17

更新日: 2018/11/15

依存関係: sendmail_detect.nbin

リスク情報

CVSS スコアのソース: CVE-2003-0694

VPR

リスクファクター: Medium

スコア: 6.3

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.8

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 10

Temporal Score: 9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:a:sendmail:sendmail:*:*:*:*:*:*:*:*

必要な KB アイテム: installed_sw/Sendmail

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2003/9/17

脆弱性公開日: 2003/9/17

参照情報

CVE: CVE-2003-0694, CVE-2003-0681

BID: 8641, 8649

CERT: 108964

RHSA: 2003:283

SuSE: SUSE-SA