PHP < 4.3.3 の複数の脆弱性

high Nessus プラグイン ID 11850

概要

任意のコードがリモートサーバーで実行されることがあります。

説明

リモートホストは、4.3.3 より古いバージョンの PHP を実行しています。

4.3.3 より古い すべてのバージョンの PHP 4 には、複数の整数オーバーフロー脆弱性が含まれており、これによって攻撃者が、このホストで任意のコマンドを実行できることがあります。他の問題も、safe_mode を無効にすることがあります。

ソリューション

PHP 4.3.3 にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-4.php

プラグインの詳細

深刻度: High

ID: 11850

ファイル名: php4_multiple_flaws.nasl

バージョン: 1.36

タイプ: remote

ファミリー: CGI abuses

公開日: 2003/9/24

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

脆弱性公開日: 2002/12/27

参照情報

CVE: CVE-2002-1396, CVE-2003-0442, CVE-2003-0860, CVE-2003-0861

BID: 6488, 7761, 8693, 8696

RHSA: 2003:204-01

SuSE: SUSE-SA:2003:0009