SUSE SLED12 / SLES12セキュリティ更新プログラム:openssl(SUSE-SU-2018:3866-1)

medium Nessus プラグイン ID 119117

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新プログラムがありません。

説明

このopensslの更新では、次の問題を修正します:

修正されたセキュリティ問題:

CVE-2018-0734:DSA署名生成におけるタイミングの脆弱性が修正されました(bsc#1113652)。

CVE-2018-5407:楕円曲線のスカラー乗法タイミング攻撃に対する防御が修正されました(bsc#1113534)。

DSA署名生成に欠落しているタイミングサイドチャネルパッチを追加します(bsc#1113742)。

修正されたセキュリティ以外の問題:不適切なパラメーターによるDSA生成の無限ループが修正されました(bsc#1112209)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE OpenStack Cloud 7:zypper in -t patch SUSE-OpenStack-Cloud-7-2018-2760=1

SUSE Linux Enterprise Software Development Kit 12-SP3:zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-2760=1

SUSE Linux Enterprise Server for SAP 12-SP2:zypper in -t patch SUSE-SLE-SAP-12-SP2-2018-2760=1

SUSE Linux Enterprise Server 12-SP3:zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-2760=1

SUSE Linux Enterprise Server 12-SP2-LTSS:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-2760=1

SUSE Linux Enterprise Server 12-SP2-BCL:zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2018-2760=1

SUSE Linux Enterprise Desktop 12-SP3:zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-2760=1

SUSE Enterprise Storage 4:zypper in -t patch SUSE-Storage-4-2018-2760=1

SUSE CaaS Platform ALL:

この更新プログラムをインストールするには、SUSE CaaS Platform Velumダッシュボードを使用してください。新しい更新を検出した場合は通知され、その後、制御された方法でクラスター全体の更新をトリガーできます。

SUSE CaaS Platform 3.0:

この更新プログラムをインストールするには、SUSE CaaS Platform Velumダッシュボードを使用してください。新しい更新を検出した場合は通知され、その後、制御された方法でクラスター全体の更新をトリガーできます。

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-2760=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1112209

https://bugzilla.suse.com/show_bug.cgi?id=1113534

https://bugzilla.suse.com/show_bug.cgi?id=1113652

https://bugzilla.suse.com/show_bug.cgi?id=1113742

https://www.suse.com/security/cve/CVE-2018-0734/

https://www.suse.com/security/cve/CVE-2018-5407/

http://www.nessus.org/u?272b53d7

プラグインの詳細

深刻度: Medium

ID: 119117

ファイル名: suse_SU-2018-3866-1.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2018/11/23

更新日: 2021/1/13

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.1

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.4

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:N

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.9

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libopenssl-devel, p-cpe:/a:novell:suse_linux:libopenssl1_0_0, p-cpe:/a:novell:suse_linux:libopenssl1_0_0-debuginfo, p-cpe:/a:novell:suse_linux:libopenssl1_0_0-hmac, p-cpe:/a:novell:suse_linux:openssl, p-cpe:/a:novell:suse_linux:openssl-debuginfo, p-cpe:/a:novell:suse_linux:openssl-debugsource, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/11/22

脆弱性公開日: 2018/10/30

参照情報

CVE: CVE-2018-0734, CVE-2018-5407