Jenkins < 2.138.4 LTS/2.150.1 LTS/2.154の複数の脆弱性

critical Nessus プラグイン ID 119500
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーでホストされているジョブスケジューリング/管理システムは、複数の脆弱性の影響を受けます。

説明

リモートWebサーバーで実行されているJenkinsのバージョンは2.154より前であるか、2.138.4または2.150.1より前のJenkins LTSのバージョンです。したがって、複数の脆弱性の影響を受けます。- 細工されたURLを介して呼び出される特定のメソッドが原因で、Jenkinsで使用されるStapler Webフレームワークにコマンド実行の脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、この方法での呼び出しが意図されていないメソッドを呼び出すことができます。これにより、コマンドが実行される可能があります。- ユーザーレコードの強制移行によるサービス拒否(DoS)の脆弱性がJenkinsにあります。認証されていないリモートの攻撃者が、細工されたユーザー名をJenkinsログインに送信することにより、この問題を悪用する可能性があります。これにより、有効なユーザーがログインできなくなる可能性があります。- ワークスペースブラウザーがワークスペース外のシンボリックリンクをたどっているため、任意のファイルの読み取りの脆弱性がJenkinsにあります。攻撃者がこれを悪用し、ワークスペース外の任意のファイルを読み取り、秘密情報を漏えいする可能性があります。- cron表現形式の検証にエラーがあるため、サービス拒否(DoS)の脆弱性がJenkinsにあります。攻撃者がこの問題を悪用し、細工したcron表現を使用して、アプリケーションの応答を停止させる可能性があります。Nessusはこれらの問題のテストを行っておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Jenkinsをバージョン2.154以降に、Jenkins LTSをバージョン2.138.4、2.150.1以降にアップグレードしてください。

関連情報

https://jenkins.io/security/advisory/2018-12-05/

https://www.tenable.com/security/research/tra-2018-43

プラグインの詳細

深刻度: Critical

ID: 119500

ファイル名: jenkins_2_154.nasl

バージョン: 1.7

タイプ: remote

ファミリー: CGI abuses

公開日: 2018/12/7

更新日: 2019/5/29

依存関係: jenkins_detect.nasl

リスク情報

CVSS スコアのソース: CVE-2018-1000861

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 8.3

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:F/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.1

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:cloudbees:jenkins

必要な KB アイテム: www/Jenkins

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/12/5

脆弱性公開日: 2018/12/5

エクスプロイト可能

Metasploit (Jenkins ACL Bypass and Metaprogramming RCE)

参照情報

CVE: CVE-2018-1000861, CVE-2018-1000862, CVE-2018-1000863, CVE-2018-1000864