Squid 3.x < 3.5.18/4.x < 4.0.10複数のサービス拒否の脆弱性(SQUID-2016:9)

high Nessus プラグイン ID 119723

概要

リモートのプロキシサーバーは、複数のサービス拒否の脆弱性の影響を受けます。

説明

バナーによると、リモートホストで実行しているSquidのバージョンは、3.5.18より前の3.xまたは4.0.10より前の4.xです。したがって、ポインターの処理と参照カウントが不適切であるため、ESI応答処理コンポーネントに複数のサービス拒否(DoS)の脆弱性の影響を受けます。リモートの攻撃者がコントロールするサーバーがこれを悪用し、細工されたESI応答を通じて、Squidサービスにアクセスするすべてのクライアントにサービス拒否を引き起こす可能性があります。Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Squidバージョン3.5.18/4.0.10以降にアップグレードしてください。または、ベンダーから提供されたパッチを適用します。

関連情報

http://www.squid-cache.org/Advisories/SQUID-2016_9.txt

プラグインの詳細

深刻度: High

ID: 119723

ファイル名: squid_2016_9.nasl

バージョン: 1.2

タイプ: remote

ファミリー: Firewalls

公開日: 2018/12/17

更新日: 2019/10/31

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2016-4555

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:squid-cache:squid

必要な KB アイテム: installed_sw/Squid, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/5/6

脆弱性公開日: 2016/5/6

参照情報

CVE: CVE-2016-4555, CVE-2016-4556