Squid 3.1.12.1 <= 3.1.x <= 3.1.23/3.2.0.4 <= 3.2.x/3.3.x/3.4.x/3.5.x <= 3.5.28/4.x <4.4クロスサイトスクリプティングの脆弱性(SQUID-2018:4)

medium Nessus プラグイン ID 119726

概要

リモートのプロキシサーバーは、クロスサイトスクリプティングの脆弱性の影響を受けます。

説明

バナーによると、リモートホストで実行しているSquidのバージョンは、3.1.12.1以降で3.1.23以前の3.1.x、3.2.0.4以降の3.2.x、3.3.x、3.4.x、3.5.28以前の3.5.x、または4.4より前の4.xです。したがって、ユーザーに返す前のユーザー指定入力の検証が不適切であるため、クロスサイトスクリプティング(XSS)の脆弱性の影響を受けます。リモートの攻撃者がコントロールするサーバーがこれを悪用し、任意のスクリプトコードが挿入されたエラーページをクライアントに配信し、そのスクリプトコードをクライアントのブラウザーセッションで実行される可能性があります。Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Squidバージョン4.4以降にアップグレードしてください。または、ベンダーから提供されたパッチを適用します。

関連情報

http://www.squid-cache.org/Advisories/SQUID-2018_4.txt

プラグインの詳細

深刻度: Medium

ID: 119726

ファイル名: squid_2018_4.nasl

バージョン: 1.2

タイプ: remote

ファミリー: Firewalls

公開日: 2018/12/17

更新日: 2019/10/31

構成: パラノイドモードの有効化

リスク情報

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2018-19131

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:squid-cache:squid

必要な KB アイテム: installed_sw/Squid, Settings/ParanoidReport

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/10/17

脆弱性公開日: 2018/10/28

参照情報

CVE: CVE-2018-19131