openSUSEセキュリティ更新プログラム:perl(openSUSE-2018-1595)

critical Nessus プラグイン ID 119863

言語:

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

perl 用のこの更新では、次の問題を修正しています:

修正されたセキュリティ問題:

- CVE-2018-18311:オーバーサイズの環境による整数オーバーフローを修正しました(bsc#1114674)。

- CVE-2018-18312:ヒープバッファオーバーフロー書き込み/reg_nodeオーバーランを修正しました(bsc#1114675)。

- CVE-2018-18313:正規表現に\ 0文字が含まれる場合のヒープバッファオーバーフローの読み取りを修正しました(bsc#1114681)。

- CVE-2018-18314:正規表現のヒープバッファオーバーフローを修正しました(bsc#1114686)。

この更新はSUSEからインポートされました:SLE-15:更新プロジェクトを更新します。

ソリューション

影響を受けるperlパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1114674

https://bugzilla.opensuse.org/show_bug.cgi?id=1114675

https://bugzilla.opensuse.org/show_bug.cgi?id=1114681

https://bugzilla.opensuse.org/show_bug.cgi?id=1114686

プラグインの詳細

深刻度: Critical

ID: 119863

ファイル名: openSUSE-2018-1595.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2018/12/24

更新日: 2021/1/19

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: Critical

Base Score: 9.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-32bit-debuginfo, p-cpe:/a:novell:opensuse:perl-base, p-cpe:/a:novell:opensuse:perl-base-32bit, p-cpe:/a:novell:opensuse:perl-base-32bit-debuginfo, p-cpe:/a:novell:opensuse:perl-base-debuginfo, p-cpe:/a:novell:opensuse:perl-debuginfo, p-cpe:/a:novell:opensuse:perl-debugsource, cpe:/o:novell:opensuse:15.0

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

パッチ公開日: 2018/12/22

参照情報

CVE: CVE-2018-18311, CVE-2018-18312, CVE-2018-18313, CVE-2018-18314