pfSense 2.3.x < 2.3.5-p2/2.4.x < 2.4.4の複数の脆弱性(SA-18_06/SA-18_07/SA-18_08)

high Nessus プラグイン ID 119887

概要

リモートのファイアウォールホストは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートのpfSenseのインストールは、2.3.5-p2以前の2.3.xまたは2.4.3-p1より前の2.4.xです。したがって、以下の複数の脆弱性の影響を受けます。-投機的実行とアドレス変換を利用するマイクロプロセッサを搭載したシステムでは、ターミナルページフォルトとサイドチャネル分析を通じて、L1データキャッシュに存在する情報がローカルユーザーアクセスを持つ攻撃者に不正に開示される可能性があります。(CVE-2018-3620)- 2.4.4より前のpfSenseでは、dhcp_relinquish_lease()によるstatus_interfaces.phpに、認証済みのコマンドインジェクションの脆弱性があります。これにより、影響を受けるページに対する権限を持つ認証済みWebGUIユーザーが、DHCPでアドレスを取得するよう構成されているインターフェイスのDHCPリースを放棄するリクエストを送信するときに、rootユーザーのコンテキストでコマンドを実行する可能性があります。(CVE-2018-16055)- システムリソースの過剰消費のため、サービス拒否の脆弱性がIPフラグメントの再アセンブリコードにあります。この問題により、任意のIPフラグメントを送信できるリモートの攻撃者が、マシンにリソースを過剰消費させる可能性があります。(CVE-2018-6923)

ソリューション

pfSenseバージョン2.4.4以降にアップグレードするか、ベンダーアドバイザリに記載されているパッチを適用してください。

関連情報

http://www.nessus.org/u?c44a2d3c

http://www.nessus.org/u?b33cf0ad

http://www.nessus.org/u?db4f32a9

http://www.nessus.org/u?7d4d989a

プラグインの詳細

深刻度: High

ID: 119887

ファイル名: pfsense_SA-18_08.nasl

バージョン: 1.4

タイプ: remote

ファミリー: Firewalls

公開日: 2018/12/27

更新日: 2019/10/31

リスク情報

VPR

リスクファクター: Medium

スコア: 6

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:F/RL:OF/RC:C

CVSS スコアのソース: CVE-2018-16055

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 8.2

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:F/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

必要な KB アイテム: Host/pfSense

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/8/9

脆弱性公開日: 2018/8/9

エクスプロイト可能

CANVAS (CANVAS)

参照情報

CVE: CVE-2018-3620, CVE-2018-3646, CVE-2018-6922, CVE-2018-6923, CVE-2018-6924, CVE-2018-14526, CVE-2018-15473, CVE-2018-16055