SUSE SLES12セキュリティ更新プログラム:nodejs4 (SUSE-SU-2016:2470-1)

high Nessus プラグイン ID 119982

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

この更新により、新しいアップストリームnodejsLTSバージョン4.6.0が導入され、バグとセキュリティの問題を修正します:

- Nodejs埋め込みopensslバージョンの更新

+ 1.0.2jにアップグレードします(CVE-2016-6304、CVE-2016-2183、CVE-2016-2178、CVE-2016-6306、CVE-2016-7052)

+ 動的サードパーティエンジンモジュールのサポートを削除します

- http:入力ユーザーデータの許容文字を適切に検証します。
これにより、HTTP応答の構成時にスローが発生する可能性がある新しいケースが導入されます。ユーザーはすでにここでtry/catchを導入している必要があります。
(CVE-2016-5325、bsc#985201)

- tls:ワイルドカード証明書が適切に検証されます(CVE-2016-7099、bsc#1001652)

- buffer:Buffer.concat()により作成される新しいBufferオブジェクトで超過バイトがゼロフィルされます

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

この SUSE セキュリティ更新をインストールするには、YaST online_update を使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Module for Web Scripting 12:zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2016-1439=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1001652

https://bugzilla.suse.com/show_bug.cgi?id=985201

https://www.suse.com/security/cve/CVE-2016-2178/

https://www.suse.com/security/cve/CVE-2016-2183/

https://www.suse.com/security/cve/CVE-2016-5325/

https://www.suse.com/security/cve/CVE-2016-6304/

https://www.suse.com/security/cve/CVE-2016-6306/

https://www.suse.com/security/cve/CVE-2016-7052/

https://www.suse.com/security/cve/CVE-2016-7099/

http://www.nessus.org/u?20d40afc

プラグインの詳細

深刻度: High

ID: 119982

ファイル名: suse_SU-2016-2470-1.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/1/2

更新日: 2021/1/6

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2016-2183

VPR

リスクファクター: Medium

スコア: 6.2

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:nodejs4, p-cpe:/a:novell:suse_linux:nodejs4-debuginfo, p-cpe:/a:novell:suse_linux:nodejs4-debugsource, p-cpe:/a:novell:suse_linux:nodejs4-devel, p-cpe:/a:novell:suse_linux:npm4, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/10/6

脆弱性公開日: 2016/6/20

参照情報

CVE: CVE-2016-2178, CVE-2016-2183, CVE-2016-5325, CVE-2016-6304, CVE-2016-6306, CVE-2016-7052, CVE-2016-7099