SUSE SLED15 / SLES15セキュリティ更新プログラム:ghostscript(SUSE-SU-2018:4087-1)

critical Nessus プラグイン ID 120186

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このghostscriptのバージョン9.26への更新では、次の問題を修正します:

修正されたセキュリティ問題:

CVE-2018-19475:psi/zdevice2.cでの意図的なアクセス制限のバイパスを修正しました(bsc#1117327)

CVE-2018-19476:psi/zicc.cでの意図的なアクセス制限のバイパスを修正しました(bsc#1117313)

CVE-2018-19477:psi/zfjbig2.cでの意図的なアクセス制限のバイパスを修正しました(bsc#1117274)

CVE-2018-19409:LockSafetyParamsで別のデバイスが使用されているかどうかを正しくチェックします(bsc#1117022)

CVE-2018-18284:1Policyオペレーターによるサンドボックスエスケープの可能性を修正しました(bsc#1112229)

CVE-2018-18073:保存された実行スタックのオペレーターによる漏洩を修正しました(bsc#1111480)

CVE-2018-17961:executeonlyのバイパスによる-dSAFERサンドボックスエスケープを修正しました(bsc#1111479)

CVE-2018-17183:特別に細工されたPostScriptファイルによるコードインジェクションの可能性を修正しました(bsc#1109105)

9.26(bsc#1117331)へのバージョン更新:主要な焦点はセキュリティ問題でした

マイナーなバグ修正と改善

リリースサマリーの参照先: http://www.ghostscript.com/doc/9.26/News.htm

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2018-2914=1

SUSE Linux Enterprise Module for Desktop Applications 15:zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2018-2914=1

SUSE Linux Enterprise Module for Basesystem 15:zypper in -t patch SUSE-SLE-Module-Basesystem-15-2018-2914=1

関連情報

https://www.ghostscript.com/doc/9.26/News.htm

https://bugzilla.suse.com/show_bug.cgi?id=1109105

https://bugzilla.suse.com/show_bug.cgi?id=1111479

https://bugzilla.suse.com/show_bug.cgi?id=1111480

https://bugzilla.suse.com/show_bug.cgi?id=1112229

https://bugzilla.suse.com/show_bug.cgi?id=1117022

https://bugzilla.suse.com/show_bug.cgi?id=1117274

https://bugzilla.suse.com/show_bug.cgi?id=1117313

https://bugzilla.suse.com/show_bug.cgi?id=1117327

https://bugzilla.suse.com/show_bug.cgi?id=1117331

https://www.suse.com/security/cve/CVE-2018-17183/

https://www.suse.com/security/cve/CVE-2018-17961/

https://www.suse.com/security/cve/CVE-2018-18073/

https://www.suse.com/security/cve/CVE-2018-18284/

https://www.suse.com/security/cve/CVE-2018-19409/

https://www.suse.com/security/cve/CVE-2018-19475/

https://www.suse.com/security/cve/CVE-2018-19476/

https://www.suse.com/security/cve/CVE-2018-19477/

http://www.nessus.org/u?1602a3db

プラグインの詳細

深刻度: Critical

ID: 120186

ファイル名: suse_SU-2018-4087-1.nasl

バージョン: 1.9

タイプ: local

エージェント: unix

公開日: 2019/1/2

更新日: 2021/1/13

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:ghostscript, p-cpe:/a:novell:suse_linux:ghostscript-debuginfo, p-cpe:/a:novell:suse_linux:ghostscript-debugsource, p-cpe:/a:novell:suse_linux:ghostscript-devel, p-cpe:/a:novell:suse_linux:ghostscript-mini, p-cpe:/a:novell:suse_linux:ghostscript-mini-debuginfo, p-cpe:/a:novell:suse_linux:ghostscript-mini-debugsource, p-cpe:/a:novell:suse_linux:ghostscript-mini-devel, p-cpe:/a:novell:suse_linux:ghostscript-x11, p-cpe:/a:novell:suse_linux:ghostscript-x11-debuginfo, p-cpe:/a:novell:suse_linux:libspectre-debugsource, p-cpe:/a:novell:suse_linux:libspectre-devel, p-cpe:/a:novell:suse_linux:libspectre1, p-cpe:/a:novell:suse_linux:libspectre1-debuginfo, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/12/12

脆弱性公開日: 2018/9/19

参照情報

CVE: CVE-2018-17183, CVE-2018-17961, CVE-2018-18073, CVE-2018-18284, CVE-2018-19409, CVE-2018-19475, CVE-2018-19476, CVE-2018-19477

IAVB: 2019-B-0081-S