SUSE SLES12セキュリティ更新プログラム:libsoup(SUSE-SU-2018:2204-2)

critical Nessus プラグイン ID 121042

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このlibsoup用更新プログラムでは、以下の問題が修正されています:

修正されたセキュリティ問題:

CVE-2018-12910:空のホスト名を処理するときのクラッシュを修正しました(bsc#1100097)。

CVE-2017-2885:クライアントまたはサーバーに対して悪用される可能性があるチャンクデコーディングのバッファオーバーランを修正します(bsc#1052916)。

バグ修正:bsc#1086036:translation-update-upstreamがLeapに対してコメントアウトしました

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE OpenStack Cloud 7:zypper in -t patch SUSE-OpenStack-Cloud-7-2019-25=1

SUSE Linux Enterprise Server for SAP 12-SP2:zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-25=1

SUSE Linux Enterprise Server 12-SP2-LTSS:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2019-25=1

SUSE Enterprise Storage 4:zypper in -t patch SUSE-Storage-4-2019-25=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1052916

https://bugzilla.suse.com/show_bug.cgi?id=1086036

https://bugzilla.suse.com/show_bug.cgi?id=1100097

https://www.suse.com/security/cve/CVE-2017-2885/

https://www.suse.com/security/cve/CVE-2018-12910/

http://www.nessus.org/u?80b64ad4

プラグインの詳細

深刻度: Critical

ID: 121042

ファイル名: suse_SU-2018-2204-2.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/1/9

更新日: 2021/2/11

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libsoup-2_4, p-cpe:/a:novell:suse_linux:libsoup-2_4-1, p-cpe:/a:novell:suse_linux:libsoup-2_4-1-debuginfo, p-cpe:/a:novell:suse_linux:libsoup-debugsource, p-cpe:/a:novell:suse_linux:typelib-1_0-Soup, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/1/8

脆弱性公開日: 2018/4/24

参照情報

CVE: CVE-2017-2885, CVE-2018-12910