Foxit PhantomPDF < 9.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 121045

Synopsis

A PDF toolkit installed on the remote Windows host is affected by a multiple vulnerabilities.

Description

According to its version, the Foxit PhantomPDF application (formally known as Phantom) installed on the remote Windows host is prior to 9.4. It is, therefore, affected by multiple vulnerabilities:

- An out-of-bounds read/write vulnerability and crash when handling XFA element attributes. (CVE-2018-3956)

- A signature validation bypass vulnerability which could lead to incorrect validation results.
(CVE-2018-18688, CVE-2018-18689)

Additionally, the application was affected by multiple potential information disclosure, denial of service, and remote code execution vulnerabilities.

Solution

Upgrade to Foxit PhantomPDF version 9.4 or later.

See Also

https://www.foxitsoftware.com/support/security-bulletins.php

Plugin Details

Severity: Medium

ID: 121045

File Name: foxit_phantom_9_4.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 2019/01/09

Updated: 2019/02/26

Dependencies: 49807

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-3956

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:/a:foxitsoftware:phantom, cpe:/a:foxitsoftware:phantompdf

Patch Publication Date: 2019/01/03

Vulnerability Publication Date: 2019/01/03

Reference Information

CVE: CVE-2018-3956, CVE-2018-18688, CVE-2018-18689