Foxit Reader < 9.4 Multiple Vulnerabilities

Medium Nessus Plugin ID 121046


A PDF viewer installed on the remote Windows host is affected by multiple vulnerabilities.


The version of Foxit Reader installed on the remote Windows host is prior to 9.4. It is, therefore, affected by multiple vulnerabilities:

- An out-of-bounds read/write vulnerability and crash when handling XFA element attributes. (CVE-2018-3956)

- A signature validation bypass vulnerability which could lead to incorrect validation results.
(CVE-2018-18688, CVE-2018-18689)

Additionally, the application was affected by multiple potential information disclosure, denial of service, and remote code execution vulnerabilities.


Upgrade to Foxit PhantomPDF version 9.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 121046

File Name: foxit_reader_9_4.nasl

Version: 1.3

Type: local

Agent: windows

Family: Windows

Published: 2019/01/09

Updated: 2019/02/26

Dependencies: 32395

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-3956

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H

Vulnerability Information

CPE: cpe:/a:foxitsoftware:foxit_reader

Patch Publication Date: 2019/01/03

Vulnerability Publication Date: 2019/01/03

Reference Information

CVE: CVE-2018-3956, CVE-2018-18688, CVE-2018-18689