Wireshark 2.4.x < 2.4.12 Multiple Vulnerabilities

Medium Nessus Plugin ID 121107

Synopsis

An application installed on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Wireshark installed on the remote Windows host is 2.4.x prior to 2.4.12. It is, therefore, affected by multiple denial of service vulnerabilities in the following protocol dissectors:

- P_MUL

- RTSE

- ISAKMP

- ENIP

- TCAP

- ASN.1 BER and related

- RPCAP

An attacker could cause Wireshark to crash by injecting a malformed packet onto the wire, or by convincing a user to read a malformed packet trace file.

Solution

Upgrade to Wireshark version 2.4.12 or later.

See Also

https://www.wireshark.org/docs/relnotes/wireshark-2.4.12.html

https://www.wireshark.org/security/wnpa-sec-2019-01.html

https://www.wireshark.org/security/wnpa-sec-2019-02.html

https://www.wireshark.org/security/wnpa-sec-2019-03.html

https://www.wireshark.org/security/wnpa-sec-2019-04.html

https://www.wireshark.org/security/wnpa-sec-2019-05.html

https://www.wireshark.org/security/wnpa-sec-2019-06.html

https://www.wireshark.org/security/wnpa-sec-2019-07.html

https://www.wireshark.org/security/wnpa-sec-2019-08.html

Plugin Details

Severity: Medium

ID: 121107

File Name: wireshark_2_4_12.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2019/01/11

Updated: 2019/04/18

Dependencies: 34112

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-5719

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: installed_sw/Wireshark, SMB/Registry/Enumerated

Patch Publication Date: 2019/01/08

Vulnerability Publication Date: 2019/01/08

Reference Information

CVE: CVE-2019-5717, CVE-2019-5718, CVE-2019-5719, CVE-2019-9208, CVE-2019-9209, CVE-2019-9214

BID: 106482, 107146, 107203