Apache Tomcat 7.0.x < 7.0.70/8.0.x < 8.0.36/8.5.x < 8.5.3/9.0.x < 9.0.0.M8のサービス拒否

high Nessus プラグイン ID 121119
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのApache Tomcatサーバーは、サービス拒否の脆弱性の影響を受けます。

説明

自己報告されたバージョン番号によると、リモートホストでリッスンしているApache Tomcatインスタンスは、7.0.70より前の7.0.x、8.0.36より前の8.0.x、8.5.3より前の8.5.x、または9.0.0.M8より前の9.0.xです。したがって、サービス拒否の脆弱性の影響を受けます。- Commons FileUploadにサービス拒否の脆弱性が見つかりました。これは、マルチパート境界が通常のように数十バイトの長さで、境界の長さが、アップロードされたファイルの読み取りに使用するバッファサイズ(4096バイト)未満であるときに発生しました。Nessusはこれらの問題をテストしていませんが、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache Tomcatバージョン7.0.70/8.0.36/8.5.3/9.0.0.M8以降にアップグレードしてください。

関連情報

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.70

http://www.nessus.org/u?ecb3da27

http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.0.M8

プラグインの詳細

深刻度: High

ID: 121119

ファイル名: tomcat_7_0_70.nasl

バージョン: 1.5

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2019/1/11

更新日: 2020/3/11

依存関係: tomcat_error_version.nasl, tomcat_win_installed.nbin, apache_tomcat_nix_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2016-3092

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 5.8

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/6/20

脆弱性公開日: 2016/3/10

参照情報

CVE: CVE-2016-3092