Joomla! Extension 'JCK Suite' - 'jckeditor' =< 6.4.4 Privilege Escalation

High Nessus Plugin ID 121255

Synopsis

The remote Joomla! application has a plugin installed that is vulnerable
to a sql injection attack.

Description

The Joomla! application running on the remote host has a version of
'JCK Suite' - 'jckeditor' extension that is prior or equal to 6.4.4.
As such, the host is affected by a SQL injection (SQLi) vulnerability
exists due to improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit this to inject or
manipulate SQL queries in the back-end database, resulting in the
disclosure or manipulation of arbitrary data.

Solution

Update the 'JCK Suite' - 'jckeditor' extension through the
administrative dashboard.

See Also

https://extensions.joomla.org/extension/jck-editor/

https://www.exploit-db.com/exploits/45423

Plugin Details

Severity: High

ID: 121255

File Name: joomla_extension_jcksuite_6_4_4.nasl

Version: 1.1

Type: remote

Family: CGI abuses

Published: 2019/01/21

Modified: 2019/01/21

Dependencies: 121256

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Standard sql injection

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Vulnerability Publication Date: 2018/09/14