PHP 7.3.x < 7.3.1の複数の脆弱性

critical Nessus プラグイン ID 121475
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストにインストールされているアプリケーションは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは7.3.1より前の7.3.xです。したがって、複数の脆弱性の影響を受けます。- gd_interpolation.cの_gdContributionsAlloc関数に整数アンダーフローの状態があります。認証されていないリモートの攻撃者が、u変数の減少に関連するベクトルを使用して、詳細不明な影響を与える可能性があります。(CVE-2016-10166)- 割り当てられたバッファサイズが不適切に計算されているため、gdImageColorMatchにヒープベースのバッファオーバーフロー状態があります。攻撃者がこの脆弱性を悪用し、パラメーターとして細工された画像データでimagecolormatch関数を呼び出す可能性があります。(CVE-2019-6977)- 入力データの検証が不適切なため、xmlrpc_decode関数にヒープベースのバッファオーバーリードがあります。認証されていないリモートの攻撃者は、特別に細工されたリクエストを介してこれを悪用し、ヒープの領域外読み取りまたは解放後読み取り状態を引き起こし、システムが完全に侵害される可能性があります。(CVE-2019-9020)- メモリ操作の実装が不適切なため、PHAR拡張のPHAR読み取り関数にヒープベースのバッファーのオーバーリードがあります。認証されていないリモートの攻撃者がこれを悪用し、ユーザーを誘導して特別に細工されたファイル名を標的となるシステムで解析させ、秘密情報を漏えいする可能性があります。(CVE-2019-9021)-メモリ操作の実装が不適切なため、複数のヒープベースのバッファオーバーリードインスタンスがmbstringの正規表現関数に存在します。認証されていないリモートの攻撃者がこれを悪用し、マルチバイトシーケンスを含む特別に細工された正規表現を送信して、攻撃者が標的システムを完全に侵害できる条件を引き起こす可能性があります。(CVE-2019-9023)- メモリ操作の実装が不適切なため、xmlrpc_decode関数に領域外読み取りエラーが存在します。認証されていないリモートの攻撃者はこれを悪用し、悪意のあるXMLRPCサーバーを介して、割り当てられた領域外のメモリからPHPを読み取らせる可能性があります。(CVE-2019-9024)- メモリ操作が不適切に実装されているため、mb_split関数に領域外読み取りおよび書き込みエラーが存在します。認証されていないリモートの攻撃者がこれを悪用し、負の引数を指定してmemcpy関数をPHPに実行させ、バッファオーバーリードとオーバーライトの状態を引き起こし、攻撃者がシステムを完全に侵害する可能性があります。(CVE-2019-9025)

ソリューション

PHPバージョン7.3.1以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.3.1

プラグインの詳細

深刻度: Critical

ID: 121475

ファイル名: php_7_3_1.nasl

バージョン: 1.5

タイプ: remote

ファミリー: CGI abuses

公開日: 2019/1/30

更新日: 2019/5/2

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2016-10166

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/1/10

脆弱性公開日: 2019/1/10

参照情報

CVE: CVE-2016-10166, CVE-2019-6977, CVE-2019-9020, CVE-2019-9021, CVE-2019-9023, CVE-2019-9024, CVE-2019-9025

BID: 95869, 106731, 107156