LibreOffice 6.1.x < 6.1.3.2 Arbitrary Code Execution

High Nessus Plugin ID 121544

Synopsis

An application installed on the remote host is affected by an an arbitrary code execution vulnerability.

Description

The version of LibreOffice installed on the remote Windows host is 6.1.x prior to 6.1.3.2. It is, therefore, affected by an an arbitrary code execution vulnerability as a result of a path traversal vulnerability allowing the ability to run any local python script, in addition to being able to pass user defined parameters to default python modules and functions included with libreoffice.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to LibreOffice version 6.1.3.2 or later.

See Also

http://www.nessus.org/u?b37c8646

Plugin Details

Severity: High

ID: 121544

File Name: libreoffice_6132.nasl

Version: 1.2

Type: local

Agent: windows

Family: Windows

Published: 2019/02/01

Updated: 2019/02/08

Dependencies: 55573

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-16858

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Patch Publication Date: 2018/10/30

Vulnerability Publication Date: 2019/02/01

Reference Information

CVE: CVE-2018-16858

IAVB: 2019-B-0012