LibreOffice 6.1.x < Arbitrary Code Execution

High Nessus Plugin ID 121544


An application installed on the remote host is affected by an an arbitrary code execution vulnerability.


The version of LibreOffice installed on the remote Windows host is 6.1.x prior to It is, therefore, affected by an an arbitrary code execution vulnerability as a result of a path traversal vulnerability allowing the ability to run any local python script, in addition to being able to pass user defined parameters to default python modules and functions included with libreoffice.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to LibreOffice version or later.

See Also

Plugin Details

Severity: High

ID: 121544

File Name: libreoffice_6132.nasl

Version: 1.5

Type: local

Agent: windows

Family: Windows

Published: 2019/02/01

Updated: 2019/04/30

Dependencies: 55573

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-16858

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:libreoffice:libreoffice

Required KB Items: installed_sw/LibreOffice, SMB/Registry/Enumerated

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/10/30

Vulnerability Publication Date: 2019/02/01

Exploitable With

Metasploit (LibreOffice Macro Code Execution)

Reference Information

CVE: CVE-2018-16858

IAVB: 2019-B-0012