Apache OpenOffice < 4.1.6 Virtual Table Arithmetic Overflow

Medium Nessus Plugin ID 122033

Synopsis

The remote Windows host has an application installed that is affected by an overflow vulnerability.

Description

The version of Apache OpenOffice installed on the remote host is a version prior to 4.1.6. It is, therefore, affected by an arithmetic overflow flaw related to handling virtual tables. This error could allow code execution.

Solution

Upgrade to Apache OpenOffice version 4.1.6 or later.

See Also

https://www.openoffice.org/security/cves/CVE-2018-11790.html

http://www.nessus.org/u?2c28b446

https://ssd-disclosure.com/index.php/archives/3758

Plugin Details

Severity: Medium

ID: 122033

File Name: openoffice_416.nasl

Version: 1.1

Type: local

Agent: windows

Family: Windows

Published: 2019/02/08

Updated: 2019/02/08

Dependencies: 25551

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-11790

CVSS v2.0

Base Score: 4.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apache:openoffice

Required KB Items: installed_sw/OpenOffice

Patch Publication Date: 2019/01/25

Vulnerability Publication Date: 2019/01/06

Reference Information

CVE: CVE-2018-11790

BID: 106803

IAVA: 2019-A-0040