Apache 2.4.x < 2.4.33の複数の脆弱性

critical Nessus プラグイン ID 122060
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストで実行しているApacheのバージョンは、2.4.33より前の2.4.xです。そのため、以下の複数の脆弱性の影響を受けます。

- 領域外書き込みの脆弱性がAuthLDAPCharsetConfigを有効にしたmod_authnz_ldapにあります。認証されていないリモートの攻撃者がこれを悪用し、Accept-Languageヘッダーを介してアプリケーションの応答を停止させる可能性があります。(CVE-2017-15710)
- 任意のファイルアップロードの脆弱性がFilesMatchコンポーネントにあります。そして、悪意のあるファイル名が改行文字の表現チェックに一致するよう細工される可能性があります。認証されていないリモートの攻撃者がこれを悪用し、改行文字を介してユーザーの権限で、リモートホストに任意のファイルをアップロードする可能性があります。(CVE-2017-15715)

- SessionEnvが有効になっており、そのセッションデータをCGIアプリケーションに転送しているため、セッション管理の脆弱性がmod_sessionコンポーネントにあります。認証されていないリモートの攻撃者がこれを悪用し、HTTP_SESSIONを改ざんしてセッションヘッダーを使用し、コンテンツに影響を及ぼす可能性があります。(CVE-2018-1283)

- サイズ制限に達すると、領域外アクセスが生じる脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、Apache HTTPサーバーをクラッシュさせる可能性があります。(CVE-2018-1301)

- 解放されたメモリの領域にNULLポインターが書き込まれるため、書き込み後に解放される脆弱性がHTTP/2ストリームにあります。認証されていないリモート攻撃者がこの脆弱性を悪用し、任意のコードを実行する可能性があります。(CVE-2018-1302)
- 領域外読み取りの生じる脆弱性がmod_cache_socacheにあります。
認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたHTTPリクエストヘッダーを使用して、アプリケーションの応答を停止させる可能性があります。(CVE-2018-1303)

- 弱いダイジェストの脆弱性がHTTPダイジェスト認証の課題にあります。認証されていないリモートの攻撃者がこれを悪用し、一般的なダイジェスト認証を使用するよう構成されたサーバークラスタで、検出されずにサーバー間でHTTPリクエストを再生する可能性があります。(CVE-2018-1312)

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apacheバージョン2.4.33以降にアップグレードしてください。

関連情報

https://archive.apache.org/dist/httpd/CHANGES_2.4.33

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.33

プラグインの詳細

深刻度: Critical

ID: 122060

ファイル名: apache_2_4_33.nasl

バージョン: 1.5

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2019/2/8

更新日: 2021/1/28

依存関係: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2018-1312

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

必要な KB アイテム: installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/3/21

脆弱性公開日: 2018/3/21

参照情報

CVE: CVE-2017-15710, CVE-2017-15715, CVE-2018-1283, CVE-2018-1301, CVE-2018-1302, CVE-2018-1303, CVE-2018-1312

BID: 103512, 103515, 103524, 103525, 103528, 104584, 106158