SUSE SLES12セキュリティ更新プログラム:nodejs6 (SUSE-SU-2019:0395-1)

high Nessus プラグイン ID 122230

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

nodejs6用のこの更新プログラムは、バージョン6.16.0に更新し、以下の問題が修正されています:

修正されたセキュリティ問題:

CVE-2018-0734:DSA署名生成におけるタイミングの脆弱性が修正されました(bsc#1113652)。

CVE-2018-5407:ハイパースレッドポートコンテンツサイドチャネル攻撃(別名「PortSmash」)を修正しました(bsc#1113534)

CVE-2018-12120:デフォルトでデバッガーがどのインターフェイスでもリッスンするよう修正しました(bsc#1117625)

CVE-2018-12121:大きなHTTPヘッダーによるサービス拒否を修正しました(bsc#1117626)

CVE-2018-12122:Slowloris HTTPのサービス拒否を修正しました(bsc#1117627)

CVE-2018-12116:HTTPリクエストの分割を修正しました(bsc#1117630)

CVE-2018-12123:JavaScriptプロトコルのURLパーサーにおけるホスト名のなりすましを修正しました(bsc#1117629)

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE OpenStack Cloud Crowbar 8:zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2019-395=1

SUSE OpenStack Cloud 7:zypper in -t patch SUSE-OpenStack-Cloud-7-2019-395=1

SUSE Linux Enterprise Module for Web Scripting 12:zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2019-395=1

SUSE Enterprise Storage 4:zypper in -t patch SUSE-Storage-4-2019-395=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1113534

https://bugzilla.suse.com/show_bug.cgi?id=1113652

https://bugzilla.suse.com/show_bug.cgi?id=1117625

https://bugzilla.suse.com/show_bug.cgi?id=1117626

https://bugzilla.suse.com/show_bug.cgi?id=1117627

https://bugzilla.suse.com/show_bug.cgi?id=1117629

https://bugzilla.suse.com/show_bug.cgi?id=1117630

https://www.suse.com/security/cve/CVE-2018-0734/

https://www.suse.com/security/cve/CVE-2018-12116/

https://www.suse.com/security/cve/CVE-2018-12120/

https://www.suse.com/security/cve/CVE-2018-12121/

https://www.suse.com/security/cve/CVE-2018-12122/

https://www.suse.com/security/cve/CVE-2018-12123/

https://www.suse.com/security/cve/CVE-2018-5407/

http://www.nessus.org/u?2f969e13

プラグインの詳細

深刻度: High

ID: 122230

ファイル名: suse_SU-2019-0395-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2019/2/15

更新日: 2019/9/10

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:nodejs6, p-cpe:/a:novell:suse_linux:nodejs6-debuginfo, p-cpe:/a:novell:suse_linux:nodejs6-debugsource, p-cpe:/a:novell:suse_linux:nodejs6-devel, p-cpe:/a:novell:suse_linux:npm6, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/2/14

脆弱性公開日: 2018/10/30

参照情報

CVE: CVE-2018-0734, CVE-2018-12116, CVE-2018-12120, CVE-2018-12121, CVE-2018-12122, CVE-2018-12123, CVE-2018-5407