Adobe Reader < 2019.010.20091 / 2017.011.30120 / 2015.006.30475 Multiple Vulnerabilities (APSB19-07)

High Nessus Plugin ID 122253

Synopsis

The version of Adobe Reader installed on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Adobe Reader installed on the remote Windows host is prior to 2019.010.20091, 2017.011.30120, 2015.006.30475. It is, therefore, affected by multiple vulnerabilities as referenced in the APSB19-07 advisory.

- Buffer Errors potentially leading to Arbitrary Code Execution (CVE-2019-7020, CVE-2019-7085)

- Data leakage (sensitive) potentially leading to Information Disclosure (CVE-2019-7089)

- Double Free potentially leading to Arbitrary Code Execution (CVE-2019-7080)

- Integer Overflow potentially leading to Information Disclosure (CVE-2019-7030)

- Out-of-Bounds Read potentially leading to Information Disclosure (CVE-2019-7021, CVE-2019-7022, CVE-2019-7023, CVE-2019-7024, CVE-2019-7028, CVE-2019-7032, CVE-2019-7033, CVE-2019-7034, CVE-2019-7035, CVE-2019-7036, CVE-2019-7038, CVE-2019-7045, CVE-2019-7047, CVE-2019-7049, CVE-2019-7053, CVE-2019-7055, CVE-2019-7056, CVE-2019-7057, CVE-2019-7058, CVE-2019-7059, CVE-2019-7063, CVE-2019-7064, CVE-2019-7065, CVE-2019-7067, CVE-2019-7071, CVE-2019-7073, CVE-2019-7074, CVE-2019-7081)

- Security bypass potentially leading to Privilege Escalation (CVE-2018-19725, CVE-2019-7041)

- Out-of-Bounds Write potentially leading to Arbitrary Code Execution (CVE-2019-7019, CVE-2019-7027, CVE-2019-7037, CVE-2019-7039, CVE-2019-7052, CVE-2019-7060, CVE-2019-7079)

- Type Confusion potentially leading to Arbitrary Code Execution (CVE-2019-7069, CVE-2019-7086, CVE-2019-7087)

- Untrusted Pointer Dereference potentially leading to Arbitrary Code Execution (CVE-2019-7042, CVE-2019-7046, CVE-2019-7051, CVE-2019-7054, CVE-2019-7066, CVE-2019-7076)

- Use After Free potentially leading to Arbitrary Code Execution (CVE-2019-7018, CVE-2019-7025, CVE-2019-7026, CVE-2019-7029, CVE-2019-7031, CVE-2019-7040, CVE-2019-7043, CVE-2019-7044, CVE-2019-7048, CVE-2019-7050, CVE-2019-7062, CVE-2019-7068, CVE-2019-7070, CVE-2019-7072, CVE-2019-7075, CVE-2019-7077, CVE-2019-7078, CVE-2019-7082, CVE-2019-7083, CVE-2019-7084)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Reader version 2019.010.20091 / 2017.011.30120 / 2015.006.30475 or later.

See Also

https://helpx.adobe.com/security/products/acrobat/apsb19-07.html

Plugin Details

Severity: High

ID: 122253

File Name: adobe_reader_apsb19-07.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2019/02/15

Updated: 2019/04/02

Dependencies: 20836

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-7080

CVSS v2.0

Base Score: 9.4

Temporal Score: 8.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.1

Temporal Score: 8.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat_reader

Required KB Items: SMB/Registry/Enumerated, installed_sw/Adobe Reader

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/02/12

Vulnerability Publication Date: 2019/02/12

Reference Information

CVE: CVE-2018-19725, CVE-2019-7018, CVE-2019-7019, CVE-2019-7020, CVE-2019-7021, CVE-2019-7022, CVE-2019-7023, CVE-2019-7024, CVE-2019-7025, CVE-2019-7026, CVE-2019-7027, CVE-2019-7028, CVE-2019-7029, CVE-2019-7030, CVE-2019-7031, CVE-2019-7032, CVE-2019-7033, CVE-2019-7034, CVE-2019-7035, CVE-2019-7036, CVE-2019-7037, CVE-2019-7038, CVE-2019-7039, CVE-2019-7040, CVE-2019-7041, CVE-2019-7042, CVE-2019-7043, CVE-2019-7044, CVE-2019-7045, CVE-2019-7046, CVE-2019-7047, CVE-2019-7048, CVE-2019-7049, CVE-2019-7050, CVE-2019-7051, CVE-2019-7052, CVE-2019-7053, CVE-2019-7054, CVE-2019-7055, CVE-2019-7056, CVE-2019-7057, CVE-2019-7058, CVE-2019-7059, CVE-2019-7060, CVE-2019-7062, CVE-2019-7063, CVE-2019-7064, CVE-2019-7065, CVE-2019-7066, CVE-2019-7067, CVE-2019-7068, CVE-2019-7069, CVE-2019-7070, CVE-2019-7071, CVE-2019-7072, CVE-2019-7073, CVE-2019-7074, CVE-2019-7075, CVE-2019-7076, CVE-2019-7077, CVE-2019-7078, CVE-2019-7079, CVE-2019-7080, CVE-2019-7081, CVE-2019-7082, CVE-2019-7083, CVE-2019-7084, CVE-2019-7085, CVE-2019-7086, CVE-2019-7087, CVE-2019-7089

BID: 106973, 106974, 106975, 106977, 106978, 106979, 106980, 106981, 106983, 106985